From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752878AbbIPIVx (ORCPT ); Wed, 16 Sep 2015 04:21:53 -0400 Received: from www.linutronix.de ([62.245.132.108]:46948 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752002AbbIPIVu (ORCPT ); Wed, 16 Sep 2015 04:21:50 -0400 Date: Wed, 16 Sep 2015 10:21:08 +0200 (CEST) From: Thomas Gleixner To: Yang Yingliang cc: linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, Jiang Liu , Marc Zyngier , Mark Rutland , Will Deacon , Russell King - ARM Linux , Hanjun Guo Subject: Re: [RFC PATCH v3 2/3] ia64: rename migrate_irqs() to avoid compiling error In-Reply-To: <1442375907-11496-3-git-send-email-yangyingliang@huawei.com> Message-ID: References: <1442375907-11496-1-git-send-email-yangyingliang@huawei.com> <1442375907-11496-3-git-send-email-yangyingliang@huawei.com> User-Agent: Alpine 2.11 (DEB 23 2013-08-11) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII X-Linutronix-Spam-Score: -1.0 X-Linutronix-Spam-Level: - X-Linutronix-Spam-Status: No , -1.0 points, 5.0 required, ALL_TRUSTED=-1,SHORTCIRCUIT=-0.0001 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 16 Sep 2015, Yang Yingliang wrote: > To avoid multi-declaration error after adding migrate_irqs into > kernel/irq/migration.c, rename migrate_irqs() to move_irqs(). And why can't you chose a different name for the generic function instead of creating useless churn in IA64? Thanks, tglx