mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: David Kershner <david.kershner@unisys.com>
Cc: corbet@lwn.net, mingo@redhat.com, hpa@zytor.com,
	gregkh@linuxfoundation.org, erik.arfvidson@unisys.com,
	Tim Sell <timothy.sell@unisys.com>,
	hofrat@osadl.org, dzickus@redhat.com, jes.sorensen@redhat.com,
	alexander.curtin@unisys.com, janani.rvchndrn@gmail.com,
	sudipm.mukherjee@gmail.com, prarit@redhat.com,
	david.binder@unisys.com, nhorman@redhat.com,
	dan.j.williams@intel.com, linux-kernel@vger.kernel.org,
	linux-doc@vger.kernel.org,
	driverdev-devel@linuxdriverproject.org,
	sparmaintainer@unisys.com
Subject: Re: [PATCH v4 09/29] staging: unisys: visorinput: remove unnecessary locking
Date: Thu, 9 Jun 2016 11:01:26 +0200 (CEST)	[thread overview]
Message-ID: <alpine.DEB.2.11.1606091059590.28031@nanos> (raw)
In-Reply-To: <1465420463-24982-10-git-send-email-david.kershner@unisys.com>

On Wed, 8 Jun 2016, David Kershner wrote:
> +	/*
> +	 * If we're not paused, really enable interrupts.
> +	 * Regardless of whether we are paused, set a flag indicating
> +	 * interrupts should be enabled so when we resume, interrupts
> +	 * will really be enabled.
> +	 */
> +	down_write(&devdata->lock_visor_dev);

I think I asked this before, but I might have missed the answer.

Why is this a rw_sempahore? It's never taken with down_read and looking at the
usage sites it's simply a mutex, right?

Thanks,

	tglx

  reply	other threads:[~2016-06-09  9:03 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-06-08 21:13 [PATCH v4 00/29] Fixed issues raised by tglx, then move visorbus to drivers/virt David Kershner
2016-06-08 21:13 ` [PATCH v4 01/29] staging: unisys: visorbus: remove return values for write_vbus functions David Kershner
2016-06-08 21:13 ` [PATCH v4 02/29] staging: unisys: visorbus: check parahotplug_request_complete_result David Kershner
2016-06-08 21:13 ` [PATCH v4 03/29] staging: unisys: visorbus: remove unused module parameters David Kershner
2016-06-08 21:13 ` [PATCH v4 04/29] staging: unisys: visorbus: remove unused struct David Kershner
2016-06-08 21:13 ` [PATCH v4 05/29] staging: unisys: visorbus: modify format string to match argument David Kershner
2016-06-08 21:14 ` [PATCH v4 06/29] staging: unisys: visornic: Correct comment spelling mistake David Kershner
2016-06-08 21:14 ` [PATCH v4 07/29] staging: unisys: include: Remove thread-related enum members David Kershner
2016-06-08 21:14 ` [PATCH v4 08/29] staging: unisys: visorbus: removed unused periodic_test_workqueue David Kershner
2016-06-08 21:14 ` [PATCH v4 09/29] staging: unisys: visorinput: remove unnecessary locking David Kershner
2016-06-09  9:01   ` Thomas Gleixner [this message]
2016-06-09 12:03     ` Sell, Timothy C
2016-06-09 19:55       ` Thomas Gleixner
2016-06-09 20:30         ` Sell, Timothy C
2016-06-11  3:34         ` Sell, Timothy C
2016-06-08 21:14 ` [PATCH v4 10/29] staging: unisys: visorbus: use kernel timer instead of workqueue David Kershner
2016-06-08 21:14 ` [PATCH v4 11/29] staging: unisys: visorbus: remove periodic_work.h/.c David Kershner
2016-06-08 21:14 ` [PATCH v4 12/29] staging: unisys: visorbus: Make visordriver_callback_lock a mutex David Kershner
2016-06-08 21:14 ` [PATCH v4 13/29] staging: unisys: visorbus: Remove unnecessary EXPORT_SYMBOL statements David Kershner
2016-06-08 21:14 ` [PATCH v4 14/29] staging: unisys: visorbus: Remove unused functions David Kershner
2016-06-08 21:14 ` [PATCH v4 15/29] staging: unisys: Remove reference to unused STANDALONE_CLIENT David Kershner
2016-06-08 21:14 ` [PATCH v4 16/29] staging: unisys: visorbus: remove unused parameter from function David Kershner
2016-06-08 21:14 ` [PATCH v4 17/29] staging: unisys: visorbus: fix commenting in vbusdevinfo.h David Kershner
2016-06-08 21:14 ` [PATCH v4 18/29] staging: unisys: visorbus: fix commenting in visorbus_main.c David Kershner
2016-06-08 21:14 ` [PATCH v4 19/29] staging: unisys: visorbus: fix visorchannel.c comments David Kershner
2016-06-08 21:14 ` [PATCH v4 20/29] staging: unisys: visorbus: Rectify commenting in visorchipset.c David Kershner
2016-06-08 21:14 ` [PATCH v4 21/29] staging: unisys: visorbus: Move visorbus-unique functions to private header David Kershner
2016-06-08 21:14 ` [PATCH v4 22/29] staging: unisys: visorbus: rectify kerneldoc comment for struct David Kershner
2016-06-08 21:14 ` [PATCH v4 23/29] staging: unisys: visorbus: Remove notifier-related code from visorbus David Kershner
2016-06-08 21:14 ` [PATCH v4 24/29] staging: unisys: visorbus: Rename function to follow existing convention David Kershner
2016-06-08 21:14 ` [PATCH v4 25/29] staging: unisys: visorbus: fix visorbus_private.h comments David Kershner
2016-06-08 21:14 ` [PATCH v4 26/29] staging: unisys: Move vbushelper.h to visorbus directory David Kershner
2016-06-08 21:14 ` [PATCH v4 27/29] include: linux: visorbus: Add visorbus to include/linux directory David Kershner
2016-06-08 21:14 ` [PATCH v4 28/29] Documentation: Move visorbus documentation from staging to Documentation/ David Kershner
2016-06-08 21:14 ` [PATCH v4 29/29] drivers: Add visorbus to the drivers/virt directory David Kershner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.11.1606091059590.28031@nanos \
    --to=tglx@linutronix.de \
    --cc=alexander.curtin@unisys.com \
    --cc=corbet@lwn.net \
    --cc=dan.j.williams@intel.com \
    --cc=david.binder@unisys.com \
    --cc=david.kershner@unisys.com \
    --cc=driverdev-devel@linuxdriverproject.org \
    --cc=dzickus@redhat.com \
    --cc=erik.arfvidson@unisys.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hofrat@osadl.org \
    --cc=hpa@zytor.com \
    --cc=janani.rvchndrn@gmail.com \
    --cc=jes.sorensen@redhat.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=nhorman@redhat.com \
    --cc=prarit@redhat.com \
    --cc=sparmaintainer@unisys.com \
    --cc=sudipm.mukherjee@gmail.com \
    --cc=timothy.sell@unisys.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®