From: Thomas Gleixner <tglx@linutronix.de>
To: Sebastian Frias <sf84@laposte.net>
Cc: Grant Likely <grant.likely@secretlab.ca>,
Marc Zyngier <marc.zyngier@arm.com>,
Jason Cooper <jason@lakedaemon.net>,
LKML <linux-kernel@vger.kernel.org>, Mason <slash.tmp@free.fr>
Subject: Re: [PATCH v2] irqdomain: factorise irq_domain_xlate_onetwocell()
Date: Mon, 1 Aug 2016 19:07:37 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.11.1608011903220.19845@nanos> (raw)
In-Reply-To: <579F635E.6090505@laposte.net>
On Mon, 1 Aug 2016, Sebastian Frias wrote:
> Commit 16b2e6e2f31d ("irq_domain: Create common xlate functions that device
> drivers can use") introduced three similar functions:
>
> irq_domain_xlate_onecell()
> irq_domain_xlate_twocell()
> irq_domain_xlate_onetwocell()
>
> yet the last one, irq_domain_xlate_onetwocell(), can be factored to use the
> two previous ones to avoid code duplication.
>
> Fixes: 16b2e6e2f31d ("irq_domain: Create common xlate functions that device
> drivers can use")
That does not fix anything. It optimizes code. We use the "Fixes" tag only
when the existing code is buggy.
> Signed-off-by: Sebastian Frias <sf84@laposte.net>
> ---
>
> NOTE: the factored code is not strictly the same in the sense that
> 16b2e6e2f31d returns "intspec[1]" as 'out_type', while this patch would
> make it return "intspec[1] & IRQ_TYPE_SENSE_MASK".
So the proper way to do that is to split this into two patches:
#1 Change the existing code to do the masking and explain why it is correct.
#2 Refactor the code and get rid of the duplicated implementation.
> Feel free to comment on that matter.
>
> ---
> kernel/irq/irqdomain.c | 9 ++++++---
> 1 file changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/irq/irqdomain.c b/kernel/irq/irqdomain.c
> index bee8b02..125a28c 100644
> --- a/kernel/irq/irqdomain.c
> +++ b/kernel/irq/irqdomain.c
> @@ -839,9 +839,12 @@ int irq_domain_xlate_onetwocell(struct irq_domain *d,
> {
> if (WARN_ON(intsize < 1))
> return -EINVAL;
> - *out_hwirq = intspec[0];
> - *out_type = (intsize > 1) ? intspec[1] : IRQ_TYPE_NONE;
> - return 0;
> + if (intsize == 1)
> + return irq_domain_xlate_onecell(d, ctrlr, intspec, intsize,
> + out_hwirq, out_type);
> + else
> + return irq_domain_xlate_twocell(d, ctrlr, intspec, intsize,
> + out_hwirq, out_type);
So I really wonder how much of a saving that change is. I wouldn't be
surprised if it would create worse code on some architectures.
Thanks,
tglx
next prev parent reply other threads:[~2016-08-01 17:10 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-01 14:27 [PATCH] " Sebastian Frias
2016-08-01 14:57 ` [PATCH v2] " Sebastian Frias
2016-08-01 17:07 ` Thomas Gleixner [this message]
2016-08-02 8:31 ` Sebastian Frias
2016-08-02 9:07 ` Sebastian Frias
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.11.1608011903220.19845@nanos \
--to=tglx@linutronix.de \
--cc=grant.likely@secretlab.ca \
--cc=jason@lakedaemon.net \
--cc=linux-kernel@vger.kernel.org \
--cc=marc.zyngier@arm.com \
--cc=sf84@laposte.net \
--cc=slash.tmp@free.fr \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®