From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1762936AbcINSyu (ORCPT ); Wed, 14 Sep 2016 14:54:50 -0400 Received: from Galois.linutronix.de ([146.0.238.70]:36311 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1762487AbcINSyr (ORCPT ); Wed, 14 Sep 2016 14:54:47 -0400 Date: Wed, 14 Sep 2016 20:52:22 +0200 (CEST) From: Thomas Gleixner To: Deepa Dinamani cc: linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org, arnd@arndb.de, torvalds@linux-foundation.org, gregkh@linuxfoundation.org, akpm@linux-foundation.org, tytso@mit.edu, viro@zeniv.linux.org.uk, y2038@lists.linaro.org Subject: Re: [PATCH v5 1/5] vfs: Add current_time() api In-Reply-To: <1473864486-30862-2-git-send-email-deepa.kernel@gmail.com> Message-ID: References: <1473864486-30862-1-git-send-email-deepa.kernel@gmail.com> <1473864486-30862-2-git-send-email-deepa.kernel@gmail.com> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 14 Sep 2016, Deepa Dinamani wrote: > +/** > + * current_time - Return FS time > + * @inode: inode. > + * > + * Return the current time truncated to the time granularity supported by > + * the fs. > + * > + * Note that inode and inode->sb cannot be NULL. > + * Otherwise, the function warns and returns time without truncation. > + */ > +struct timespec current_time(struct inode *inode) Just a nitpick. Can we please rename that to fs_current_time() or something similar which tells right away that this is a FS specific function. current_time() is pretty generic and used in many places as variable/argument name. Thanks, tglx