From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1764914AbcINUfr (ORCPT ); Wed, 14 Sep 2016 16:35:47 -0400 Received: from Galois.linutronix.de ([146.0.238.70]:36823 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1762862AbcINUfo (ORCPT ); Wed, 14 Sep 2016 16:35:44 -0400 Date: Wed, 14 Sep 2016 22:33:14 +0200 (CEST) From: Thomas Gleixner To: Deepa Dinamani cc: Linux FS-devel Mailing List , Linux Kernel Mailing List , Arnd Bergmann , Linus Torvalds , Greg KH , Andrew Morton , "Theodore Ts'o" , Alexander Viro , y2038 Mailman List Subject: Re: [PATCH v5 1/5] vfs: Add current_time() api In-Reply-To: Message-ID: References: <1473864486-30862-1-git-send-email-deepa.kernel@gmail.com> <1473864486-30862-2-git-send-email-deepa.kernel@gmail.com> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 14 Sep 2016, Deepa Dinamani wrote: > >> + * current_time - Return FS time > >> + * @inode: inode. > >> + * > >> + * Return the current time truncated to the time granularity supported by > >> + * the fs. > >> + * > >> + * Note that inode and inode->sb cannot be NULL. > >> + * Otherwise, the function warns and returns time without truncation. > >> + */ > >> +struct timespec current_time(struct inode *inode) > > > > Just a nitpick. Can we please rename that to fs_current_time() or something > > similar which tells right away that this is a FS specific > > function. current_time() is pretty generic and used in many places as > > variable/argument name. > > I proposed this as one of the names before: > https://lkml.org/lkml/2016/6/14/613 . > But, decided against it because of the inode argument. > If this is preferred, I will change the patches. > > There are only about 30 (20, outside of staging) current_time > references outside of Documentation/ It just occured to me and I can live with current_time() as well. Up to Al. Thanks, tglx