From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1758364AbcIPHxm (ORCPT ); Fri, 16 Sep 2016 03:53:42 -0400 Received: from Galois.linutronix.de ([146.0.238.70]:43826 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1757780AbcIPHxU (ORCPT ); Fri, 16 Sep 2016 03:53:20 -0400 Date: Fri, 16 Sep 2016 09:50:26 +0200 (CEST) From: Thomas Gleixner To: Kyle Huey cc: "Robert O'Callahan" , linux-kernel@vger.kernel.org, Dave Hansen , Andy Lutomirski , Dmitry Safonov <0x7f454c46@gmail.com>, Borislav Petkov , linux-api@vger.kernel.org, xen-devel@lists.xenproject.org, Ingo Molnar , "H. Peter Anvin" , "maintainer:X86 ARCHITECTURE (32-BIT AND 64-BIT)" , Jeff Dike , Richard Weinberger , Al Viro , David Howells , Anna Schumaker , Andy Lutomirski , Zach Brown , Eric B Munson , "Dmitry V. Levin" , Peter Zijlstra , Paul Gortmaker , Jiri Slaby , Andrey Ryabinin , "Michael S. Tsirkin" , Borislav Petkov , Dmitry Vyukov , Jan Beulich , Mateusz Guzik , Chuck Ebbert , Oleg Nesterov , Dmitry Safonov , "chengang@emindsoft.com.cn" , Jeff Moyer , Andrew Morton , Jiri Kosina , Milosz Tanski , "open list:USER-MODE LINUX (UML)" , "open list:USER-MODE LINUX (UML)" Subject: Re: [PATCH v3 1/3] syscalls,x86 Expose arch_prctl on x86-32. In-Reply-To: <20160915233324.6060-2-khuey@kylehuey.com> Message-ID: References: <20160915233324.6060-1-khuey@kylehuey.com> <20160915233324.6060-2-khuey@kylehuey.com> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 15 Sep 2016, Kyle Huey wrote: First of all, please add a cover letter [PATCH 0/N] to your patch series and send it with something which provides proper mail threading. See: git-send-email, quilt > arch_prctl is currently 64-bit only. Wire it up for 32-bits, as a no-op for > now. Rename the second arg to a more generic name. This changelog is useless. - it does not provide any rationale for this change, i.e. why this is required. Just because its 64bit only is not a reason. - "Rename the second arg to a more generic name" does not give any useful information. Misleading information is worse than no information. Further your patch does 5 things at once. It wants to be split into parts: 1) Rename do_arch_prctl() and change the argument name, > -long do_arch_prctl(struct task_struct *task, int code, unsigned long addr) > +long do_arch_prctl_64(struct task_struct *task, int code, unsigned long arg2) 2) Provide do_arch_prctl_common() and hook it up to the arch_prctl syscall > -long sys_arch_prctl(int code, unsigned long addr) > +SYSCALL_DEFINE2(arch_prctl, int, code, unsigned long, arg2) > { > - return do_arch_prctl(current, code, addr); > + long ret; > + > + ret = do_arch_prctl_64(current, code, arg2); > + if (ret == -EINVAL) > + ret = do_arch_prctl_common(current, code, arg2); > + > + return ret; > } 3) Implement the compat version Thanks, tflx