From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753487AbdBKIXz (ORCPT ); Sat, 11 Feb 2017 03:23:55 -0500 Received: from Galois.linutronix.de ([146.0.238.70]:34904 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750999AbdBKIXy (ORCPT ); Sat, 11 Feb 2017 03:23:54 -0500 Date: Sat, 11 Feb 2017 09:23:44 +0100 (CET) From: Thomas Gleixner To: Dmitry Safonov <0x7f454c46@gmail.com> cc: Borislav Petkov , Dmitry Safonov , open list , Ingo Molnar , "H. Peter Anvin" , Andy Lutomirski , Borislav Petkov , X86 ML , linux-mm@kvack.org Subject: Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native versions In-Reply-To: Message-ID: References: <20170130120432.6716-1-dsafonov@virtuozzo.com> <20170130120432.6716-2-dsafonov@virtuozzo.com> <20170209135525.qlwrmlo7njk3fsaq@pd.tnic> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sat, 11 Feb 2017, Dmitry Safonov wrote: > 2017-02-10 23:10 GMT+03:00 Thomas Gleixner : > > On Thu, 9 Feb 2017, Borislav Petkov wrote: > >> I can't say that I'm thrilled about the ifdeffery this is adding. > >> > >> But I can't think of a cleaner approach at a quick glance, though - > >> that's generic and arch-specific code intertwined muck. Sad face. > > > > It's trivial enough to do .... > > > > Thanks, > > > > tglx > > > > --- > > arch/x86/mm/mmap.c | 22 ++++++++++------------ > > 1 file changed, 10 insertions(+), 12 deletions(-) > > > > --- a/arch/x86/mm/mmap.c > > +++ b/arch/x86/mm/mmap.c > > @@ -55,6 +55,10 @@ static unsigned long stack_maxrandom_siz > > #define MIN_GAP (128*1024*1024UL + stack_maxrandom_size()) > > #define MAX_GAP (TASK_SIZE/6*5) > > > > +#ifndef CONFIG_COMPAT > > +# define mmap_rnd_compat_bits mmap_rnd_bits > > +#endif > > + > > >From my POV, I can't say that it's clearer to shadow mmap_compat_bits > like that then to have two functions with native/compat names. > But if you insist, I'll resend patches set with your version. You can make that #ifdef CONFIG_64BIT # define mmap32_rnd_bits mmap_compat_rnd_bits # define mmap64_rnd_bits mmap_rnd_bits #else # define mmap32_rnd_bits mmap_rnd_bits # define mmap64_rnd_bits mmap_rnd_bits #endif and use that. That's still way more readable than the unholy ifdef mess. Thanks, tglx