From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751956AbdCSK6D (ORCPT ); Sun, 19 Mar 2017 06:58:03 -0400 Received: from Galois.linutronix.de ([146.0.238.70]:33653 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751920AbdCSK57 (ORCPT ); Sun, 19 Mar 2017 06:57:59 -0400 Date: Sun, 19 Mar 2017 11:57:56 +0100 (CET) From: Thomas Gleixner To: Deepa Dinamani cc: linux-kernel@vger.kernel.org, john.stultz@linaro.org, arnd@arndb.de, y2038@lists.linaro.org Subject: Re: [RESEND PATCH 1/7] time: Delete do_sys_setimeofday() In-Reply-To: <1489900666-32268-2-git-send-email-deepa.kernel@gmail.com> Message-ID: References: <1489900666-32268-1-git-send-email-deepa.kernel@gmail.com> <1489900666-32268-2-git-send-email-deepa.kernel@gmail.com> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sat, 18 Mar 2017, Deepa Dinamani wrote: > struct timespec is not y2038 safe. The plan is to > get rid of all uses of timespec internally in the > kernel. Replace uses of timespec with timespec64. > The syscall interfaces will be changed in a separate > series. > Call to do_sys_setimeofday() is superfluous as all > the necessary checks and functions are done by the > underlying function do_sys_setimeofday64(). > Replace do_sys_setimeofday64() directly instead of > do_sys_settimeofday(). The do_sys_setimeofday64() > calls timespec64_valid() internally, which is the > same as timespec_valid(). Again, this is hard to read and contains too much useless information, struct timespec is not Y2038 safe on 32 bit machines and needs to be replaced with struct timespec64. do_sys_settimeofday() is a wrapper around do_sys_settimeofday64(). Convert all call sites to use do_sys_seetimeofday64() and remove it. > @@ -109,7 +109,7 @@ COMPAT_SYSCALL_DEFINE2(settimeofday, struct compat_timeval __user *, tv, > struct timezone __user *, tz) > { > struct timeval user_tv; > - struct timespec new_ts; > + struct timespec64 new_ts; Please use the ordering I pointed out in the other mail. Thanks, tglx