From: Thomas Gleixner <tglx@linutronix.de>
To: Kyle Huey <me@kylehuey.com>
Cc: "Robert O'Callahan" <robert@ocallahan.org>,
"Andy Lutomirski" <luto@kernel.org>,
"Ingo Molnar" <mingo@redhat.com>,
"H. Peter Anvin" <hpa@zytor.com>,
x86@kernel.org, "Paolo Bonzini" <pbonzini@redhat.com>,
"Radim Krčmář" <rkrcmar@redhat.com>,
"Jeff Dike" <jdike@addtoit.com>,
"Richard Weinberger" <richard@nod.at>,
"Alexander Viro" <viro@zeniv.linux.org.uk>,
"Shuah Khan" <shuah@kernel.org>,
"Dave Hansen" <dave.hansen@linux.intel.com>,
"Borislav Petkov" <bp@suse.de>,
"Peter Zijlstra" <peterz@infradead.org>,
"Boris Ostrovsky" <boris.ostrovsky@oracle.com>,
"Len Brown" <len.brown@intel.com>,
"Rafael J. Wysocki" <rafael.j.wysocki@intel.com>,
"Dmitry Safonov" <dsafonov@virtuozzo.com>,
"David Matlack" <dmatlack@google.com>,
"Nadav Amit" <nadav.amit@gmail.com>,
"Andi Kleen" <andi@firstfloor.org>,
"Grzegorz Andrejczuk" <grzegorz.andrejczuk@intel.com>,
linux-kernel@vger.kernel.org,
user-mode-linux-devel@lists.sourceforge.net,
user-mode-linux-user@lists.sourceforge.net,
linux-fsdevel@vger.kernel.org, linux-kselftest@vger.kernel.org,
kvm@vger.kernel.org
Subject: Re: [PATCH v16 08/10] x86/arch_prctl: Add ARCH_[GET|SET]_CPUID
Date: Mon, 20 Mar 2017 16:00:16 +0100 (CET) [thread overview]
Message-ID: <alpine.DEB.2.20.1703201558450.3599@nanos> (raw)
In-Reply-To: <20170320081628.18952-9-khuey@kylehuey.com>
On Mon, 20 Mar 2017, Kyle Huey wrote:
> --- a/arch/x86/include/uapi/asm/prctl.h
> +++ b/arch/x86/include/uapi/asm/prctl.h
> @@ -6,8 +6,17 @@
> #define ARCH_GET_FS 0x1003
> #define ARCH_GET_GS 0x1004
>
> +#define ARCH_GET_CPUID 0x1005
> +#define ARCH_SET_CPUID 0x1006
> +
> #define ARCH_MAP_VDSO_X32 0x2001
> #define ARCH_MAP_VDSO_32 0x2002
> #define ARCH_MAP_VDSO_64 0x2003
>
> +#ifdef CONFIG_CHECKPOINT_RESTORE
> +# define ARCH_MAP_VDSO_X32 0x2001
> +# define ARCH_MAP_VDSO_32 0x2002
> +# define ARCH_MAP_VDSO_64 0x2003
> +#endif
That hunk is bogus in two aspects:
- It's just a copy of the above wrapped in a ifdef
- The ifdef is broken, because the UAPI headers do not know about
that.
I dropped it.
next prev parent reply other threads:[~2017-03-20 16:12 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-03-20 8:16 [PATCH v16 0/10] x86/arch_prctl Add ARCH_[GET|SET]_CPUID for controlling the CPUID instruction Kyle Huey
2017-03-20 8:16 ` [PATCH v16 01/10] x86/msr: Rename MISC_FEATURE_ENABLES to MISC_FEATURES_ENABLES Kyle Huey
2017-03-20 16:31 ` [tip:x86/process] " tip-bot for Kyle Huey
2018-07-27 17:18 ` [PATCH v16 01/10] " Jim Mattson
2017-03-20 8:16 ` [PATCH v16 02/10] x86/arch_prctl: Rename 'code' argument to 'option' Kyle Huey
2017-03-20 16:31 ` [tip:x86/process] " tip-bot for Kyle Huey
2017-03-20 8:16 ` [PATCH v16 03/10] x86/arch_prctl/64: Use SYSCALL_DEFINE2 to define sys_arch_prctl Kyle Huey
2017-03-20 16:32 ` [tip:x86/process] x86/arch_prctl/64: Use SYSCALL_DEFINE2 to define sys_arch_prctl() tip-bot for Kyle Huey
2017-03-20 8:16 ` [PATCH v16 04/10] x86/arch_prctl/64: Rename do_arch_prctl to do_arch_prctl_64 Kyle Huey
2017-03-20 16:32 ` [tip:x86/process] x86/arch_prctl/64: Rename do_arch_prctl() to do_arch_prctl_64() tip-bot for Kyle Huey
2017-03-20 8:16 ` [PATCH v16 05/10] x86/arch_prctl: Add do_arch_prctl_common Kyle Huey
2017-03-20 16:33 ` [tip:x86/process] x86/arch_prctl: Add do_arch_prctl_common() tip-bot for Kyle Huey
2017-03-20 8:16 ` [PATCH v16 06/10] x86/syscalls/32: Wire up arch_prctl on x86-32 Kyle Huey
2017-03-20 16:33 ` [tip:x86/process] " tip-bot for Kyle Huey
2017-03-20 8:16 ` [PATCH v16 07/10] x86/cpufeature: Detect CPUID faulting support Kyle Huey
2017-03-20 16:34 ` [tip:x86/process] " tip-bot for Kyle Huey
2017-03-20 8:16 ` [PATCH v16 08/10] x86/arch_prctl: Add ARCH_[GET|SET]_CPUID Kyle Huey
2017-03-20 15:00 ` Thomas Gleixner [this message]
2017-03-20 16:39 ` Kyle Huey
2017-03-20 16:34 ` [tip:x86/process] " tip-bot for Kyle Huey
2017-03-21 8:34 ` Ingo Molnar
2017-03-21 18:33 ` Kyle Huey
2017-03-20 8:16 ` [PATCH v16 09/10] x86/arch_prctl: Selftest for ARCH_[GET|SET]_CPUID Kyle Huey
2017-10-11 3:35 ` Wanpeng Li
2017-10-11 3:56 ` Kyle Huey
2017-10-11 6:25 ` Wanpeng Li
2017-10-20 8:53 ` Thomas Gleixner
2017-03-20 8:16 ` [PATCH v16 10/10] KVM: x86: virtualize cpuid faulting Kyle Huey
2017-04-21 9:58 ` Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.20.1703201558450.3599@nanos \
--to=tglx@linutronix.de \
--cc=andi@firstfloor.org \
--cc=boris.ostrovsky@oracle.com \
--cc=bp@suse.de \
--cc=dave.hansen@linux.intel.com \
--cc=dmatlack@google.com \
--cc=dsafonov@virtuozzo.com \
--cc=grzegorz.andrejczuk@intel.com \
--cc=hpa@zytor.com \
--cc=jdike@addtoit.com \
--cc=kvm@vger.kernel.org \
--cc=len.brown@intel.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=luto@kernel.org \
--cc=me@kylehuey.com \
--cc=mingo@redhat.com \
--cc=nadav.amit@gmail.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=rafael.j.wysocki@intel.com \
--cc=richard@nod.at \
--cc=rkrcmar@redhat.com \
--cc=robert@ocallahan.org \
--cc=shuah@kernel.org \
--cc=user-mode-linux-devel@lists.sourceforge.net \
--cc=user-mode-linux-user@lists.sourceforge.net \
--cc=viro@zeniv.linux.org.uk \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®