From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751279AbdFAUur (ORCPT ); Thu, 1 Jun 2017 16:50:47 -0400 Received: from Galois.linutronix.de ([146.0.238.70]:38866 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751256AbdFAUup (ORCPT ); Thu, 1 Jun 2017 16:50:45 -0400 Date: Thu, 1 Jun 2017 22:50:42 +0200 (CEST) From: Thomas Gleixner To: Christoph Hellwig cc: LKML , John Stultz , Peter Zijlstra , Ingo Molnar Subject: Re: [patch 13/26] posix-timers: Rename do_schedule_next_timer In-Reply-To: <20170531153947.GB18802@infradead.org> Message-ID: References: <20170530211533.216608851@linutronix.de> <20170530211656.811362578@linutronix.de> <20170531153947.GB18802@infradead.org> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 31 May 2017, Christoph Hellwig wrote: > On Tue, May 30, 2017 at 11:15:46PM +0200, Thomas Gleixner wrote: > > That function is a misnomer. Rename it with a proper prefix to > > posixtimer_rearm(). > > Please also move it out of asm-generic/siginfo.h as it's implemented > and used in generic code only, and there is no arch override at all. > > In fact it seems like asm-generic/siginfo.h should probably just move > to include/linux/signinfo.h. That's one convoluted mess. # find -name siginfo.h | xargs grep 'include.*siginfo.h' ./arch/score/include/uapi/asm/siginfo.h:#include ./arch/powerpc/include/uapi/asm/siginfo.h:#include ./arch/sparc/include/asm/siginfo.h:#include ./arch/sparc/include/uapi/asm/siginfo.h:#include ./arch/metag/include/uapi/asm/siginfo.h:#include ./arch/frv/include/uapi/asm/siginfo.h:#include ./arch/x86/include/uapi/asm/siginfo.h:#include ./arch/alpha/include/uapi/asm/siginfo.h:#include ./arch/tile/include/uapi/asm/siginfo.h:#include ./arch/mn10300/include/uapi/asm/siginfo.h:#include ./arch/m32r/include/uapi/asm/siginfo.h:#include ./arch/blackfin/include/uapi/asm/siginfo.h:#include ./arch/ia64/include/asm/siginfo.h:#include ./arch/ia64/include/uapi/asm/siginfo.h:#include ./arch/arm64/include/uapi/asm/siginfo.h:#include ./arch/parisc/include/uapi/asm/siginfo.h:#include ./arch/mips/include/uapi/asm/siginfo.h:#include ./arch/s390/include/uapi/asm/siginfo.h: * Derived from "include/asm-i386/siginfo.h" ./arch/s390/include/uapi/asm/siginfo.h:#include ./arch/microblaze/include/uapi/asm/siginfo.h:#include ./include/asm-generic/siginfo.h:#include Why the heck include uapi headers asm-generic/siginfo.h ??? Thanks, tglx