From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751928AbdIAKVu (ORCPT ); Fri, 1 Sep 2017 06:21:50 -0400 Received: from Galois.linutronix.de ([146.0.238.70]:36665 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751670AbdIAKVt (ORCPT ); Fri, 1 Sep 2017 06:21:49 -0400 Date: Fri, 1 Sep 2017 12:21:46 +0200 (CEST) From: Thomas Gleixner To: Christoph Hellwig cc: Kees Cook , LKML Subject: Re: Converting struct timer_list callback argument to struct timer_list * In-Reply-To: <20170901100838.GA8891@infradead.org> Message-ID: References: <20170901100838.GA8891@infradead.org> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 1 Sep 2017, Christoph Hellwig wrote: > Good work! > > I just think that the TIMER_CONTAINER name is revolting. > > The usual name for such a helper fitting other uses like lists > and rbtrees would be timer_entry, and that also reads much better. I think the plan is to remove that thing afterward, because then the callback function is: void func(struct timer_list *timer) So I don't mind the ugly name as it should be simply removed once the tree is converted over. Thanks, tglx