From: Julia Lawall <julia.lawall@lip6.fr>
To: harsha <harshasharmaiitr@gmail.com>
Cc: gregkh@linuxfoundation.org, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org, outreachy-kernel@googlegroups.com
Subject: Re: [Outreachy kernel] [PATCH] staging: rt8712: xmit_linux: Avoid multiple assignments in a single line
Date: Fri, 8 Sep 2017 10:46:21 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.20.1709081045330.3165@hadrien> (raw)
In-Reply-To: <1504859870-13153-1-git-send-email-harshasharmaiitr@gmail.com>
On Fri, 8 Sep 2017, harsha wrote:
> Fixed coding style issue
>
> Signed-off-by: Harsha Sharma <harshasharmaiitr@gmail.com>
> ---
> drivers/staging/rtl8712/xmit_linux.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/rtl8712/xmit_linux.c b/drivers/staging/rtl8712/xmit_linux.c
> index d13fd15..03c6b0c 100644
> --- a/drivers/staging/rtl8712/xmit_linux.c
> +++ b/drivers/staging/rtl8712/xmit_linux.c
> @@ -49,8 +49,10 @@ static uint remainder_len(struct pkt_file *pfile)
> void _r8712_open_pktfile(_pkt *pktptr, struct pkt_file *pfile)
> {
> pfile->pkt = pktptr;
> - pfile->cur_addr = pfile->buf_start = pktptr->data;
> - pfile->pkt_len = pfile->buf_len = pktptr->len;
I think this may be considered to be more readable as is.
julia
> + pfile->cur_addr = pktptr->data;
> + pfile->buf_start = pfile->cur_addr;
> + pfile->pkt_len = pktptr->len;
> + pfile->buf_len = pfile->pkt_len;
> pfile->cur_buffer = pfile->buf_start;
> }
>
> --
> 1.9.1
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/1504859870-13153-1-git-send-email-harshasharmaiitr%40gmail.com.
> For more options, visit https://groups.google.com/d/optout.
>
next prev parent reply other threads:[~2017-09-08 8:46 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-08 8:37 harsha
2017-09-08 8:46 ` Julia Lawall [this message]
[not found] ` <CANMOCy3eKKvgv_r=cWV-+sL1ZwHqMJYe2ipYioxidUQ+T1cH2A@mail.gmail.com>
2017-09-08 9:21 ` [Outreachy kernel] " Julia Lawall
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.20.1709081045330.3165@hadrien \
--to=julia.lawall@lip6.fr \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=harshasharmaiitr@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=outreachy-kernel@googlegroups.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®