From: Thomas Gleixner <tglx@linutronix.de>
To: Andi Kleen <andi@firstfloor.org>
Cc: x86@kernel.org, hpa@zytor.com, linux-kernel@vger.kernel.org,
Andi Kleen <ak@linux.intel.com>
Subject: Re: [PATCH v7 5/5] x86/xsave: Using generic CPUID clearing when disabling XSAVE
Date: Thu, 5 Oct 2017 15:44:32 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.20.1710051531580.2083@nanos> (raw)
In-Reply-To: <20171004234930.5685-6-andi@firstfloor.org>
On Wed, 4 Oct 2017, Andi Kleen wrote:
> From: Andi Kleen <ak@linux.intel.com>
>
> Now that the generic CPUID clearing understands dependencies,
> it's enough to clear the XSAVE CPUID bit to clear all depending
> features when XSAVE gets disabled.
>
> So we don't need this hard to maintain explicit list
> of features depending on XSAVE anymore. Just call the generic
> clear_cpu_cap() function for XSAVE.
This changelog is hard to read and uses terms like 'CPUID clearing'. I know
what you want to say, but this is far from being precise and
understandable.
Aside of that the changelog violates as usual the changelog guidelines in
Documentation/....
Something like this would be clear and precise:
Clearing a CPU feature with setup_clear_cpu_cap() clears all features
which depend on it. Expressing feature dependencies in one place is
easier to maintain than keeping functions like
fpu__xstate_clear_all_cpu_caps() up to date.
The features which depend on XSAVE have their dependency expressed in the
dependency table, so its sufficient to clear X86_FEATURE_XSAVE.
Remove the explicit clearing of XSAVE dependend features.
Hmm?
For the code patch itself:
Reviewed-by: Thomas Gleixner <tglx@linutronix.de>
Thanks,
tglx
next prev parent reply other threads:[~2017-10-05 13:44 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-04 23:49 Support generic disabling of all XSAVE features Andi Kleen
2017-10-04 23:49 ` [PATCH v7 1/5] x86/xsave: Move xsave initialization to after parsing early parameters Andi Kleen
2017-10-05 13:04 ` Thomas Gleixner
2017-10-04 23:49 ` [PATCH v7 2/5] x86/cpuid: Add generic table for cpuid dependencies Andi Kleen
2017-10-05 13:25 ` Thomas Gleixner
2017-10-04 23:49 ` [PATCH v7 3/5] x86/cpuid: Make clearcpuid an early param Andi Kleen
2017-10-05 13:26 ` Thomas Gleixner
2017-10-04 23:49 ` [PATCH v7 4/5] x86/xsave: Make XSAVE check the base CPUID features before enabling Andi Kleen
2017-10-05 13:31 ` Thomas Gleixner
2017-10-04 23:49 ` [PATCH v7 5/5] x86/xsave: Using generic CPUID clearing when disabling XSAVE Andi Kleen
2017-10-05 13:44 ` Thomas Gleixner [this message]
-- strict thread matches above, loose matches on Subject: below --
2017-09-19 22:26 Support generic disabling of all XSAVE features Andi Kleen
2017-09-19 22:26 ` [PATCH v7 5/5] x86/xsave: Using generic CPUID clearing when disabling XSAVE Andi Kleen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.20.1710051531580.2083@nanos \
--to=tglx@linutronix.de \
--cc=ak@linux.intel.com \
--cc=andi@firstfloor.org \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®