From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753058AbdJHUox (ORCPT ); Sun, 8 Oct 2017 16:44:53 -0400 Received: from mail2-relais-roc.national.inria.fr ([192.134.164.83]:36326 "EHLO mail2-relais-roc.national.inria.fr" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751568AbdJHUow (ORCPT ); Sun, 8 Oct 2017 16:44:52 -0400 X-IronPort-AV: E=Sophos;i="5.42,496,1500933600"; d="scan'208";a="295072352" Date: Sun, 8 Oct 2017 22:44:50 +0200 (CEST) From: Julia Lawall X-X-Sender: jll@hadrien To: Sebastian Reichel cc: Liam Breck , pali.rohar@gmail.com, Linux PM mailing list , kernel-janitors@vger.kernel.org, Joe Perches , Gilles Muller , Nicolas Palix , Michal Marek , cocci@systeme.lip6.fr, linux-kernel@vger.kernel.org, kbuild test robot , Masahiro Yamada Subject: Re: [PATCH 0/2] detect identical chip data arrays In-Reply-To: <20171008203258.y7kqx7ipondxlsix@earth> Message-ID: References: <1507490321-24900-1-git-send-email-Julia.Lawall@lip6.fr> <20171008203258.y7kqx7ipondxlsix@earth> User-Agent: Alpine 2.20 (DEB 67 2015-01-07) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, 8 Oct 2017, Sebastian Reichel wrote: > Hi, > > On Sun, Oct 08, 2017 at 09:18:39PM +0200, Julia Lawall wrote: > > Rename battery.cocci as check_bq27xxx_data.cocci and adjust the warning > > messages to indicate that some structures are the same, in response to > > feedback from Liam Breck. > > > > Although check_bq27xxx_data.cocci says is requires Coccinelle 1.0.7, which > > is not yet released, it actually works with the version currently available > > on Github, eg from Coccinelle commit 3ba77b3a0f91. > > I think the rename makes sense, but I would expect the move to > happen in one go with "git send-email -M", so that it detects the > rename. I'm not actually sure what is the status of the previous version. Masahiro said applied, but I downloaded his tree and it was not there. So I thought this way would be easier. julia