mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Andy Lutomirski <luto@amacapital.net>
Cc: "Chang S. Bae" <chang.seok.bae@intel.com>,
	Andy Lutomirski <luto@kernel.org>,
	"H . Peter Anvin" <hpa@zytor.com>, Ingo Molnar <mingo@kernel.org>,
	Andi Kleen <ak@linux.intel.com>,
	Dave Hansen <dave.hansen@linux.intel.com>,
	Markus T Metzger <markus.t.metzger@intel.com>,
	Ravi Shankar <ravi.v.shankar@intel.com>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v4 7/7] x86/vdso: Move out the CPU number store
Date: Fri, 22 Jun 2018 18:18:23 +0200 (CEST)	[thread overview]
Message-ID: <alpine.DEB.2.21.1806221817280.2402@nanos.tec.linutronix.de> (raw)
In-Reply-To: <80C1F514-1B4D-4CDC-BD46-6C3AA9601446@amacapital.net>

[-- Attachment #1: Type: text/plain, Size: 564 bytes --]

On Fri, 22 Jun 2018, Andy Lutomirski wrote:
> > On Jun 22, 2018, at 8:18 AM, Thomas Gleixner <tglx@linutronix.de> wrote:
> > 
> >> On Wed, 20 Jun 2018, Chang S. Bae wrote:
> >> 
> >> +#ifdef CONFIG_X86_64
> >> +static void setup_cpu_number(int cpu)
> > 
> > This function name is really misleading. vdso_setup_cpu_and_node() or
> > something like that clearly tells what this is about.
> > 
> Ah. The big secret is that it’s not just vDSO, or at lease hpa wants to
> start using it in the entry code.

Fair enough. Still setup_cpu_number() sucks.

Thanks,

	tglx

  reply	other threads:[~2018-06-22 16:18 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-20 23:14 [PATCH v4 0/7] x86: infrastructure to enable FSGSBASE Chang S. Bae
2018-06-20 23:15 ` [PATCH v4 1/7] x86/fsgsbase/64: Introduce FS/GS base helper functions Chang S. Bae
2018-06-22 14:28   ` Thomas Gleixner
2018-06-22 14:50     ` Andy Lutomirski
2018-06-22 15:39       ` Thomas Gleixner
2018-06-22 16:08         ` Andy Lutomirski
2018-06-22 18:09     ` Bae, Chang Seok
2018-06-20 23:15 ` [PATCH v4 2/7] x86/fsgsbase/64: Make ptrace read FS/GS base accurately Chang S. Bae
2018-06-22 14:37   ` Thomas Gleixner
2018-06-20 23:15 ` [PATCH v4 3/7] x86/fsgsbase/64: Use FS/GS base helpers in core dump Chang S. Bae
2018-06-22 14:43   ` Thomas Gleixner
2018-06-20 23:15 ` [PATCH v4 4/7] x86/fsgsbase/64: Factor out load FS/GS segments from __switch_to Chang S. Bae
2018-06-22 14:32   ` Thomas Gleixner
2018-06-20 23:15 ` [PATCH v4 5/7] x86/segments/64: Rename PER_CPU segment to CPU_NUMBER Chang S. Bae
2018-06-22 14:32   ` Thomas Gleixner
2018-06-20 23:15 ` [PATCH v4 6/7] x86/vdso: Introduce CPU number helper functions Chang S. Bae
2018-06-22 15:14   ` Thomas Gleixner
2018-06-22 18:46     ` Bae, Chang Seok
2018-06-22 19:07       ` Thomas Gleixner
2018-06-20 23:15 ` [PATCH v4 7/7] x86/vdso: Move out the CPU number store Chang S. Bae
2018-06-22 15:18   ` Thomas Gleixner
2018-06-22 16:11     ` Andy Lutomirski
2018-06-22 16:18       ` Thomas Gleixner [this message]
2018-06-22 18:02         ` Bae, Chang Seok
2018-06-22 22:02           ` Andy Lutomirski
2018-06-25 15:40             ` Thomas Gleixner
2018-06-25 18:00               ` H. Peter Anvin
2018-06-25 19:40                 ` Thomas Gleixner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.21.1806221817280.2402@nanos.tec.linutronix.de \
    --to=tglx@linutronix.de \
    --cc=ak@linux.intel.com \
    --cc=chang.seok.bae@intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@amacapital.net \
    --cc=luto@kernel.org \
    --cc=markus.t.metzger@intel.com \
    --cc=mingo@kernel.org \
    --cc=ravi.v.shankar@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®