From: Julia Lawall <julia.lawall@lip6.fr>
To: Shayenne Moura <shayenneluzmoura@gmail.com>
Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <maxime.ripard@bootlin.com>,
Sean Paul <sean@poorly.run>, David Airlie <airlied@linux.ie>,
dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
outreachy-kernel@googlegroups.com
Subject: Re: [Outreachy kernel] [PATCH] drm: Rename crtc_idr as object_idr to KMS cleanups
Date: Wed, 31 Oct 2018 22:30:58 +0100 (CET) [thread overview]
Message-ID: <alpine.DEB.2.21.1810312229530.5416@hadrien> (raw)
In-Reply-To: <20181031211935.p2pxr7fh26m5dc7v@smtp.gmail.com>
On Wed, 31 Oct 2018, Shayenne Moura wrote:
> On 10/31, Julia Lawall wrote:
> >
> >
> > On Wed, 31 Oct 2018, Shayenne da Luz Moura wrote:
> >
> > > Rename 'drm_mode_config.crtc_idr' as 'drm_mode_config.object_idr',
> > > as proposed in the task description in TODO list for KMS cleanups.
> >
> > Is object_idr a field that already exists? If so, "Rename" is not the
> > best choice of words. It should be something like "use the object_idr
> > field instead of the crtc_idr field" and then explain why. "task
> > description in TODO list for KMS cleanups" isn't very helpful to
> > understand why the change should be made.
> >
> > julia
>
> Hi Julia,
>
> Thank you for your review!
>
> This patch is to solve this TODO task:
> drm_mode_config.crtc_idr is misnamed, since it contains all KMS object.
> Should be renamed to drm_mode_config.object_idr.
>
> Do you think I need to use this description in my commit message?
That seems more helpful.
But it seems that the name should actually be changed. Which means that
the structure definition should be changed too. Was that done?
julia
>
> Best,
> Shayenne
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20181031211935.p2pxr7fh26m5dc7v%40smtp.gmail.com.
> For more options, visit https://groups.google.com/d/optout.
>
next prev parent reply other threads:[~2018-10-31 21:31 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-10-31 20:57 Shayenne da Luz Moura
2018-10-31 21:02 ` [Outreachy kernel] " Julia Lawall
2018-10-31 21:19 ` Shayenne Moura
2018-10-31 21:30 ` Julia Lawall [this message]
2018-10-31 23:29 ` Shayenne Moura
2018-11-01 6:28 ` Julia Lawall
2018-10-31 23:28 ` Emil Velikov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.21.1810312229530.5416@hadrien \
--to=julia.lawall@lip6.fr \
--cc=airlied@linux.ie \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=maxime.ripard@bootlin.com \
--cc=outreachy-kernel@googlegroups.com \
--cc=sean@poorly.run \
--cc=shayenneluzmoura@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®