From: Julia Lawall <julia.lawall@lip6.fr>
To: Wambui Karuga <wambui.karugax@gmail.com>
Cc: dri-devel@lists.freedesktop.org,
maarten.lankhorst@linux.intel.com, mripard@kernel.org,
sean@poorly.run, airlied@linux.ie, daniel@ffwll.ch,
linux-kernel@vger.kernel.org, outreachy-kernel@googlegroups.com
Subject: Re: [Outreachy kernel] [Outreachy][PATCH] drm: use DIV_ROUND_UP helper macro for calculations
Date: Fri, 25 Oct 2019 12:12:23 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.21.1910251212070.3307@hadrien> (raw)
In-Reply-To: <20191025094907.3582-1-wambui.karugax@gmail.com>
On Fri, 25 Oct 2019, Wambui Karuga wrote:
> Replace open coded divisor calculations with the DIV_ROUND_UP kernel
> macro for better readability.
> Issue found using coccinelle:
> @@
> expression n,d;
> @@
> (
> - ((n + d - 1) / d)
> + DIV_ROUND_UP(n,d)
> |
> - ((n + (d - 1)) / d)
> + DIV_ROUND_UP(n,d)
> )
>
> Signed-off-by: Wambui Karuga <wambui.karugax@gmail.com>
Acked-by: Julia Lawall <julia.lawall@lip6.fr>
> ---
> drivers/gpu/drm/drm_agpsupport.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_agpsupport.c b/drivers/gpu/drm/drm_agpsupport.c
> index 6e09f27fd9d6..4c7ad46fdd21 100644
> --- a/drivers/gpu/drm/drm_agpsupport.c
> +++ b/drivers/gpu/drm/drm_agpsupport.c
> @@ -212,7 +212,7 @@ int drm_agp_alloc(struct drm_device *dev, struct drm_agp_buffer *request)
> if (!entry)
> return -ENOMEM;
>
> - pages = (request->size + PAGE_SIZE - 1) / PAGE_SIZE;
> + pages = DIV_ROUND_UP(request->size, PAGE_SIZE);
> type = (u32) request->type;
> memory = agp_allocate_memory(dev->agp->bridge, pages, type);
> if (!memory) {
> @@ -325,7 +325,7 @@ int drm_agp_bind(struct drm_device *dev, struct drm_agp_binding *request)
> entry = drm_agp_lookup_entry(dev, request->handle);
> if (!entry || entry->bound)
> return -EINVAL;
> - page = (request->offset + PAGE_SIZE - 1) / PAGE_SIZE;
> + page = DIV_ROUND_UP(request->offset, PAGE_SIZE);
> retcode = drm_bind_agp(entry->memory, page);
> if (retcode)
> return retcode;
> --
> 2.23.0
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20191025094907.3582-1-wambui.karugax%40gmail.com.
>
next prev parent reply other threads:[~2019-10-25 10:12 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-10-25 9:49 Wambui Karuga
2019-10-25 10:12 ` Julia Lawall [this message]
2019-10-25 19:40 ` [Outreachy kernel] " Daniel Vetter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.21.1910251212070.3307@hadrien \
--to=julia.lawall@lip6.fr \
--cc=airlied@linux.ie \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=outreachy-kernel@googlegroups.com \
--cc=sean@poorly.run \
--cc=wambui.karugax@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®