From: Linus Torvalds <torvalds@linux-foundation.org>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Harvey Harrison <harvey.harrison@gmail.com>,
viro@ZenIV.linux.org.uk, linux-kernel@vger.kernel.org,
mingo@elte.hu
Subject: Re: [PATCH] fix sparse warning from include/linux/mmzone.h
Date: Fri, 8 Feb 2008 14:04:55 -0800 (PST) [thread overview]
Message-ID: <alpine.LFD.1.00.0802081401410.2896@woody.linux-foundation.org> (raw)
In-Reply-To: <20080208135154.ccdac0c1.akpm@linux-foundation.org>
On Fri, 8 Feb 2008, Andrew Morton wrote:
> > #ifdef CONFIG_HIGHMEM
> > - int zone_idx = zone - zone->zone_pgdat->node_zones;
> > - return zone_idx == ZONE_HIGHMEM ||
> > - (zone_idx == ZONE_MOVABLE && zone_movable_is_highmem());
> > + const int highmem_off = ZONE_HIGHMEM * sizeof(*zone);
> > + const int movable_off = ZONE_MOVABLE * sizeof(*zone);
> > +
> > + int zone_off = (unsigned long)zone - (unsigned long)zone->zone_pgdat->node_zones;
> > + return zone_off == highmem_off ||
> > + (zone_off == movable_off && zone_movable_is_highmem());
>
> hrm. For my i386 build (and that's where CONFIG_HIGHMEM really matters)
> this patch makes mm/page_alloc.o six bytes larger, and I don't think the
> change did much for readability.
Heh, yeah. That's a very odd way to write it.
It would probably make more sense to just write it as something like
struct zone *base = zone->zone_pgdat->node_zones;
if (zone == base + ZONE_HIGHMEM ||
(zone == base + ZONE_MOVABLE && zone_movable_is_highmem());
instead.
The above is totally untested, of course.
Linus
next prev parent reply other threads:[~2008-02-08 22:06 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-02-07 20:52 Harvey Harrison
2008-02-08 21:51 ` Andrew Morton
2008-02-08 22:04 ` Linus Torvalds [this message]
2008-02-08 22:17 ` Harvey Harrison
2008-02-08 22:26 ` Ingo Molnar
2008-02-08 22:35 ` Linus Torvalds
2008-02-13 19:56 ` Harvey Harrison
2008-02-13 20:36 ` [PATCH] remove sparse warning for mmzone.h Harvey Harrison
2008-02-08 22:38 ` [PATCH] fix sparse warning from include/linux/mmzone.h Harvey Harrison
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LFD.1.00.0802081401410.2896@woody.linux-foundation.org \
--to=torvalds@linux-foundation.org \
--cc=akpm@linux-foundation.org \
--cc=harvey.harrison@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=viro@ZenIV.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®