From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756106AbYDIWJV (ORCPT ); Wed, 9 Apr 2008 18:09:21 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1753264AbYDIWJN (ORCPT ); Wed, 9 Apr 2008 18:09:13 -0400 Received: from smtp1.linux-foundation.org ([140.211.169.13]:45278 "EHLO smtp1.linux-foundation.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752918AbYDIWJM (ORCPT ); Wed, 9 Apr 2008 18:09:12 -0400 Date: Wed, 9 Apr 2008 15:08:55 -0700 (PDT) From: Linus Torvalds To: Alan Mayer cc: mingo@elte.hu, linux-kernel list Subject: Re: [PATCH] x86_64: Change FIRST_SYSTEM_VECTOR to a variable. In-Reply-To: Message-ID: References: User-Agent: Alpine 1.00 (LFD 882 2007-12-20) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 9 Apr 2008, Alan Mayer wrote: > > - set_intr_gate(RESCHEDULE_VECTOR, reschedule_interrupt); > + set_intr_gate(alloc_system_vector(RESCHEDULE_VECTOR), reschedule_interrupt); Can we please just merge that syntax and make a single function like alloc_intr_gate(RESCHEDULE_VECTOR, reschedule_interrupt); instead? Linus