mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Linus Torvalds <torvalds@linux-foundation.org>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Davide Libenzi <davidel@xmailserver.org>,
	linux-kernel@vger.kernel.org, alan@lxorguk.ukuu.org.uk,
	mingo@elte.hu, davem@davemloft.net
Subject: Re: [patch 2/6] epoll keyed wakeups v2 - introduce new *_poll() wakeup macros
Date: Tue, 3 Feb 2009 12:28:10 -0800 (PST)	[thread overview]
Message-ID: <alpine.LFD.2.00.0902031219520.3247@localhost.localdomain> (raw)
In-Reply-To: <20090203121041.23d440be.akpm@linux-foundation.org>



On Tue, 3 Feb 2009, Andrew Morton wrote:
> > 
> > Actually reading the comments helps :) It triggers an include-hell, if you 
> > make them inline. Since they're lockdep debug thingies, I think it's kinda 
> > wasted turn them into non-inline real functions, so they'd better remain 
> > macros IMO.
> 
> ho hum.  I think it'd be worth at least renaming the arguments to
> something less daft, for readability reasons.

Also, maybe we can make it an out-of-line thing rather than an inline?

Why not just make it

	extern void wake_up_nested[_poll](wait_queue_head_t *,
		[unsigned long pollflags, ] unsigned int nesting);

and then just move it out of a header file entirely by writing it as a 
real function in some *.c file that only gets compiled with 
DEBUG_LOCK_ALLOC.

Hmm? No include hell.

			Linus

  parent reply	other threads:[~2009-02-03 20:29 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-02-01 20:04 Davide Libenzi
2009-02-03  8:14 ` Andrew Morton
2009-02-03 18:24   ` Davide Libenzi
2009-02-03 19:20     ` Davide Libenzi
2009-02-03 20:10       ` Andrew Morton
2009-02-03 20:24         ` Davide Libenzi
2009-02-03 20:28         ` Linus Torvalds [this message]
2009-02-03 20:34           ` Davide Libenzi
2009-02-03 20:53             ` Linus Torvalds
2009-02-03 18:28   ` Davide Libenzi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.2.00.0902031219520.3247@localhost.localdomain \
    --to=torvalds@linux-foundation.org \
    --cc=akpm@linux-foundation.org \
    --cc=alan@lxorguk.ukuu.org.uk \
    --cc=davem@davemloft.net \
    --cc=davidel@xmailserver.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®