From: Thomas Gleixner <tglx@linutronix.de>
To: Jaswinder Singh Rajput <jaswinder@kernel.org>
Cc: Ingo Molnar <mingo@elte.hu>, x86 maintainers <x86@kernel.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [git-pull -tip] x86: cleanup 20090317
Date: Tue, 17 Mar 2009 09:38:35 +0100 (CET) [thread overview]
Message-ID: <alpine.LFD.2.00.0903170930311.29264@localhost.localdomain> (raw)
In-Reply-To: <1237267595.2480.9.camel@ht.satnam>
On Tue, 17 Mar 2009, Jaswinder Singh Rajput wrote:
> On Mon, 2009-03-16 at 23:33 +0100, Thomas Gleixner wrote:
> > On Tue, 17 Mar 2009, Jaswinder Singh Rajput wrote:
> >
> > > -static struct clock_event_device pit_clockevent = {
> > > +static struct clock_event_device pit_dev = {
> >
> > Why do we need to change the name of the variable ? Just for fun or
> > is pit_dev more self explaining than pit_clockevent ?
>
> pit already means it is a clock event, but with this change:
>
> 1. we save 8 characters per declaration
> 2. It solves various 80 characters problem
There is not a single 80 character problem in that file.
> this declaration is just few lines above the code where we are using it,
> so it will not be problem. So it seems worth to me.
>
> If you still thinks this stinks, let me know I will revert it :-)
Yes it does. It's just a change with no value.
> Here is new pull request:
>
> The following changes since commit 1f31834fbbb8de367914f044d3268c6afbfdd783:
> Ingo Molnar (1):
> Merge branch 'x86/mce2'
>
> are available in the git repository at:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/jaswinder/linux-2.6-tip.git master
>
> Jaswinder Singh Rajput (10):
> x86: mpparse cleanup
> x86: cpu/intel.c cleanup
These two are the only useful ones, but the actual code changes are
mixed into mechanical cleanup noise. We want to have that separate.
Thanks,
tglx
next prev parent reply other threads:[~2009-03-17 8:40 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-03-16 18:45 Jaswinder Singh Rajput
2009-03-16 22:33 ` Thomas Gleixner
2009-03-17 5:26 ` Jaswinder Singh Rajput
2009-03-17 8:38 ` Thomas Gleixner [this message]
2009-03-17 8:50 ` Jaswinder Singh Rajput
2009-03-17 10:26 ` Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LFD.2.00.0903170930311.29264@localhost.localdomain \
--to=tglx@linutronix.de \
--cc=jaswinder@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®