From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753975Ab0AHUkP (ORCPT ); Fri, 8 Jan 2010 15:40:15 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1753928Ab0AHUkO (ORCPT ); Fri, 8 Jan 2010 15:40:14 -0500 Received: from vms173009pub.verizon.net ([206.46.173.9]:40864 "EHLO vms173009pub.verizon.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752289Ab0AHUkN (ORCPT ); Fri, 8 Jan 2010 15:40:13 -0500 Date: Fri, 08 Jan 2010 15:39:52 -0500 (EST) From: Len Brown X-X-Sender: lenb@localhost.localdomain To: "Rafael J. Wysocki" Cc: Jesse Barnes , Matthew Garrett , LKML , pm list , Alan Stern , ACPI Devel Maling List , Linux PCI , Oliver Neukum , Bjorn Helgaas , Shaohua Li , Francois Romieu Subject: Re: [PATCH 8/12] ACPI / PM: Add more run-time wake-up fields In-reply-to: <200912272105.30352.rjw@sisk.pl> Message-id: References: <200912272057.10443.rjw@sisk.pl> <200912272105.30352.rjw@sisk.pl> User-Agent: Alpine 2.00 (LFD 1167 2008-08-23) MIME-version: 1.0 Content-type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org > Use the run_wake flag to mark all devices for which run-time wake-up > events may be generated by the platform. Introduce a new wake-up > flag, special, for marking devices that should be permanently enabled > to generate run-time events. how about calling the flag "always_enabled" rather than "special"? otherwise, Acked-by: Len Brown