From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753180Ab0CURgM (ORCPT ); Sun, 21 Mar 2010 13:36:12 -0400 Received: from smtp1.linux-foundation.org ([140.211.169.13]:49392 "EHLO smtp1.linux-foundation.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752269Ab0CURgL (ORCPT ); Sun, 21 Mar 2010 13:36:11 -0400 Date: Sun, 21 Mar 2010 10:31:52 -0700 (PDT) From: Linus Torvalds To: "Rafael J. Wysocki" cc: Peter Zijlstra , pm list , LKML , Ingo Molnar , Andrew Morton Subject: Re: [Regression, post-2.6.34-rc1][PATCH] x86 / perf: Fix suspend to RAM on HP nx6325 In-Reply-To: <201003202148.01312.rjw@sisk.pl> Message-ID: References: <201003201507.15358.rjw@sisk.pl> <1269106609.9440.529.camel@laptop> <201003202148.01312.rjw@sisk.pl> User-Agent: Alpine 2.00 (LFD 1167 2008-08-23) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sat, 20 Mar 2010, Rafael J. Wysocki wrote: > > The appended patch fixes the breakage for me too. Please don't use a 'goto' for something like this. > raw_spin_lock(&amd_nb_lock); > > + if (!cpuhw->amd_nb) > + goto unlock; > + > if (--cpuhw->amd_nb->refcnt == 0) > kfree(cpuhw->amd_nb); > > cpuhw->amd_nb = NULL; > > + unlock: > raw_spin_unlock(&amd_nb_lock); > } Just do raw_spin_lock(&amd_nb_lock); if (cpuhw->amd_nb) { if (!--cpuhw->amd_nb->refcnt) kfree(cpuhw->amd_nb); cpuhw->amd_nb = NULL; } raw_spin_unlock(&amd_nb_lock); instead. Much more readable. Let's keep 'goto' for cases where we have error returns that we don't want to nest, not trivial stuff like this. Linus