mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Andi Kleen <andi@firstfloor.org>
Cc: torvalds@linux-foundation.org, linux-kernel@vger.kernel.org,
	Andi Kleen <ak@linux.intel.com>,
	ralf@linux-mips.org, tony.luck@intel.com
Subject: Re: [PATCH] Define _addr_lsb in siginfo_t for mips and ia64
Date: Fri, 8 Oct 2010 20:27:31 +0200 (CEST)	[thread overview]
Message-ID: <alpine.LFD.2.00.1010082015480.13094@localhost6.localdomain6> (raw)
In-Reply-To: <1286560501-26843-1-git-send-email-andi@firstfloor.org>

On Fri, 8 Oct 2010, Andi Kleen wrote:

> From: Andi Kleen <ak@linux.intel.com>
> 
> Define an _addr_lsb field in the mips and ia64 siginfo_ts, following
> the asm-generic version. This just puts the field over padding.
> 
> This fixes a compilation problem introduced with a337fda.

But it does not fix the mess you created in kernel/signal.c (aside of
the completely braindaed #ifdef, it's whitespace damaged) with a two
days old patch which has neither seen next, nor been reviewed by
people who care about core code nor been cross-compiled which is
mandatory for core kernel code changes.

The correct fix is to revert the patch in kernel/signal.c and fix this
proper in .37. This put_user is missing since .32 when you introduced
that grossly misnamed si extension, so there is no rush to get this in
during the late -rc cycle.

Thanks

	tglx

> Cc: ralf@linux-mips.org
> Cc: tony.luck@intel.com
> Signed-off-by: Andi Kleen <ak@linux.intel.com>
> ---
>  arch/ia64/include/asm/siginfo.h |    1 +
>  arch/mips/include/asm/siginfo.h |    1 +
>  2 files changed, 2 insertions(+), 0 deletions(-)
> 
> diff --git a/arch/ia64/include/asm/siginfo.h b/arch/ia64/include/asm/siginfo.h
> index 118d429..d20bf96 100644
> --- a/arch/ia64/include/asm/siginfo.h
> +++ b/arch/ia64/include/asm/siginfo.h
> @@ -62,6 +62,7 @@ typedef struct siginfo {
>  			int _imm;		/* immediate value for "break" */
>  			unsigned int _flags;	/* see below */
>  			unsigned long _isr;	/* isr */
> +			short _addr_lsb;
>  		} _sigfault;
>  
>  		/* SIGPOLL */
> diff --git a/arch/mips/include/asm/siginfo.h b/arch/mips/include/asm/siginfo.h
> index 96e28f1..709f7d4 100644
> --- a/arch/mips/include/asm/siginfo.h
> +++ b/arch/mips/include/asm/siginfo.h
> @@ -88,6 +88,7 @@ typedef struct siginfo {
>  #ifdef __ARCH_SI_TRAPNO
>  			int _trapno;	/* TRAP # which caused the signal */
>  #endif
> +			short _addr_lsb;	
>  		} _sigfault;
>  
>  		/* SIGPOLL, SIGXFSZ (To do ...)  */
> -- 
> 1.7.1
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
> 

      parent reply	other threads:[~2010-10-08 18:27 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-10-08 17:55 Andi Kleen
2010-10-08 18:13 ` Luck, Tony
2010-10-11 16:53   ` Tony Luck
2010-10-11 17:11     ` Andi Kleen
2010-10-08 18:27 ` Thomas Gleixner [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.2.00.1010082015480.13094@localhost6.localdomain6 \
    --to=tglx@linutronix.de \
    --cc=ak@linux.intel.com \
    --cc=andi@firstfloor.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ralf@linux-mips.org \
    --cc=tony.luck@intel.com \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®