From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757355Ab2GMTU3 (ORCPT ); Fri, 13 Jul 2012 15:20:29 -0400 Received: from www.linutronix.de ([62.245.132.108]:46259 "EHLO Galois.linutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751147Ab2GMTU2 (ORCPT ); Fri, 13 Jul 2012 15:20:28 -0400 Date: Fri, 13 Jul 2012 21:20:19 +0200 (CEST) From: Thomas Gleixner To: Seiji Aguchi cc: Steven Rostedt , "linux-kernel@vger.kernel.org" , "fweisbec@gmail.com" , "'mingo@elte.hu' (mingo@elte.hu)" , "vnagarnaik@google.com" , "x86@kernel.org" , "dle-develop@lists.sourceforge.net" , Satoru Moriya Subject: RE: [PATCH]trace,x86: add x86 irq vector tracepoints In-Reply-To: Message-ID: References: <1341521053.21574.22.camel@gandalf.stny.rr.com> User-Agent: Alpine 2.02 (LFD 1266 2009-07-14) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII X-Linutronix-Spam-Score: -1.0 X-Linutronix-Spam-Level: - X-Linutronix-Spam-Status: No , -1.0 points, 5.0 required, ALL_TRUSTED=-1,SHORTCIRCUIT=-0.0001 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 13 Jul 2012, Seiji Aguchi wrote: > > Those x86 specific ones are not really frequently raised vectors, > > so enabling them all won't affect performance and readability of > > the traces too much. > > OK. I will unify these to a single tracepoint. > "x86_irq_vector" or so? I'd rather see a real generic one, which can be used by other architectures for their esoteric non common vectors as well. Something like misc_vector_entry/exit. Any better name is welcome :) Thanks, tglx