From: Daniel Barkalow <barkalow@iabervon.org>
To: Christoph Hellwig <hch@infradead.org>
Cc: Ingo Molnar <mingo@elte.hu>,
linux-kernel@vger.kernel.org, Dave Jones <davej@redhat.com>
Subject: Re: fishy code in arch/x86/kernel/tsc.c:time_cpufreq_notifier()
Date: Mon, 1 Jun 2009 18:54:23 -0400 (EDT) [thread overview]
Message-ID: <alpine.LNX.2.00.0906011749170.2147@iabervon.org> (raw)
In-Reply-To: <20090601142104.GA15907@infradead.org>
On Mon, 1 Jun 2009, Christoph Hellwig wrote:
> Just notice the following error from gcc 4.4:
>
> arch/x86/kernel/tsc.c: In function 'time_cpufreq_notifier':
> arch/x86/kernel/tsc.c:634: warning: 'dummy' may be used uninitialized in this function
>
> dummy is only used in the following way in this function:
>
> lpj = &dummy;
>
> and then dummy might be overriden in the following odd way:
>
> if (!(freq->flags & CPUFREQ_CONST_LOOPS))
> #ifdef CONFIG_SMP
> lpj = &cpu_data(freq->cpu).loops_per_jiffy;
> #else
> lpj = &boot_cpu_data.loops_per_jiffy;
> #endif
This is misindented; the if applies to both CONFIG_SMP and otherwise. For
that matter, cpu_data(anything) == boot_cpu_data if !CONFIG_SMP. So the
current code is equivalent to:
if (!(freq->flags & CPUFREQ_CONST_LOOPS))
lpj = &cpu_data(freq->cpu).loops_per_jiffy;
> and then is used in
>
> if (!ref_freq) {
> ref_freq = freq->old;
> loops_per_jiffy_ref = *lpj;
> tsc_khz_ref = tsc_khz;
> }
>
> to me that looks like it can indeed be used unitialized for the case
> where we do have CONFIG_SMP set, freq->flags & CPUFREQ_CONST_LOOPS is
> true and ref_freq is false.
>
> Can that case actually happen?
Looks to me like loops_per_jiffy_ref is only used to compute a new value
for *lpj. So the case that matters is if this function can be called the
first time with freq->flags & CPUFREQ_CONST_LOOPS and then without;
otherwise, the uninitialized values only contribute to a dead assignment
(and the junk in the static variable).
I'd guess that, if freq->flags & CPUFREQ_CONST_LOOPS, no processor's
loops_per_jiffy should get scaled, so the current code is essentially
correct, although it's hard to read and far too hard for the compiler to
analyze.
Probably the right answer is to move the *lpj = ... in with
mark_tsc_unstable and drop the earlier if and dummy.
-Daniel
*This .sig left intentionally blank*
prev parent reply other threads:[~2009-06-01 22:54 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-06-01 14:21 Christoph Hellwig
2009-06-01 16:29 ` Dave Jones
2009-06-01 16:39 ` Christoph Hellwig
2009-06-01 20:56 ` Jon Masters
2009-06-01 21:49 ` Michael S. Zick
2009-06-01 21:50 ` Michael S. Zick
2009-06-01 22:54 ` Daniel Barkalow [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LNX.2.00.0906011749170.2147@iabervon.org \
--to=barkalow@iabervon.org \
--cc=davej@redhat.com \
--cc=hch@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®