From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751708AbeEBVCI (ORCPT ); Wed, 2 May 2018 17:02:08 -0400 Received: from namei.org ([65.99.196.166]:59166 "EHLO namei.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751148AbeEBVCG (ORCPT ); Wed, 2 May 2018 17:02:06 -0400 Date: Thu, 3 May 2018 07:01:55 +1000 (AEST) From: James Morris To: Tyler Hicks cc: linux-kernel@vger.kernel.org, Kees Cook , Andy Lutomirski , Will Drewry , Paul Moore , Eric Paris , Steve Grubb , Jonathan Corbet , linux-audit@redhat.com, linux-security-module@vger.kernel.org, linux-doc@vger.kernel.org Subject: Re: [PATCH v2 1/4] seccomp: Separate read and write code for actions_logged sysctl In-Reply-To: <1525276400-7161-2-git-send-email-tyhicks@canonical.com> Message-ID: References: <1525276400-7161-1-git-send-email-tyhicks@canonical.com> <1525276400-7161-2-git-send-email-tyhicks@canonical.com> User-Agent: Alpine 2.21 (LRH 202 2017-01-01) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 2 May 2018, Tyler Hicks wrote: > Break the read and write paths of the kernel.seccomp.actions_logged > sysctl into separate functions to maintain readability. An upcoming > change will need to audit writes, but not reads, of this sysctl which > would introduce too many conditional code paths on whether or not the > 'write' parameter evaluates to true. > > Signed-off-by: Tyler Hicks Reviewed-by: James Morris -- James Morris