From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751450Ab0LUFIG (ORCPT ); Tue, 21 Dec 2010 00:08:06 -0500 Received: from smtp-out.google.com ([216.239.44.51]:53161 "EHLO smtp-out.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750932Ab0LUFIE (ORCPT ); Tue, 21 Dec 2010 00:08:04 -0500 DomainKey-Signature: a=rsa-sha1; c=nofws; d=google.com; s=beta; h=date:from:x-x-sender:to:cc:subject:in-reply-to:message-id :references:user-agent:mime-version:content-type; b=H2GqVhZXz5EFH/Qmvu83ouz//qXTQjCKKV89sLNBak9Sz36+uWOIQANEjlFqYc6ttP VTjtexXwAdOiCxJrNtog== Date: Mon, 20 Dec 2010 21:07:51 -0800 (PST) From: Hugh Dickins X-X-Sender: hughd@tigran.mtv.corp.google.com To: Minchan Kim cc: Christoph Hellwig , Andrew Morton , linux-mm , LKML Subject: Re: [RFC 0/5] Change page reference hanlding semantic of page cache In-Reply-To: Message-ID: References: <20101220103307.GA22986@infradead.org> User-Agent: Alpine 2.00 (LSU 1167 2008-08-23) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII X-System-Of-Record: true Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 21 Dec 2010, Minchan Kim wrote: > On Mon, Dec 20, 2010 at 7:33 PM, Christoph Hellwig wrote: > > You'll need to merge all patches into one, otherwise you create really > > nasty memory leaks when bisecting between them. > > > > Okay. I will resend. > > Thanks for the notice, Christoph. Good point from hch, but I feel even more strongly: if you're going to do this now, please rename remove_from_page_cache (delete_from_page_cache was what I chose back when I misdid it) - you're changing an EXPORTed function in a subtle (well, subtlish) confusing way, which could easily waste people's time down the line, whether in not-yet-in-tree filesystems or backports of fixes. I'd much rather you break someone's build, forcing them to look at what changed, than crash or leak at runtime. If you do rename, you can keep your patch structure, introducing the new function as a wrapper to the old at the beginning, then removing the old function at the end. (As you know, I do agree that it's right to decrement the reference count at the point of removing from page cache.) Hugh