mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Hugh Dickins <hughd@google.com>
To: Andrea Arcangeli <aarcange@redhat.com>
Cc: Andi Kleen <andi@firstfloor.org>,
	linux-kernel@vger.kernel.org, Andi Kleen <ak@linux.intel.com>
Subject: Re: [PATCH 06/11] huge-memory: Use lockdep_assert_held
Date: Fri, 16 Mar 2012 14:18:57 -0700 (PDT)	[thread overview]
Message-ID: <alpine.LSU.2.00.1203161411160.1258@eggly.anvils> (raw)
In-Reply-To: <20120316194436.GN24602@redhat.com>

On Fri, 16 Mar 2012, Andrea Arcangeli wrote:
> On Fri, Mar 16, 2012 at 12:00:59PM -0700, Andi Kleen wrote:
> > From: Andi Kleen <ak@linux.intel.com>
> > 
> > Use lockdep_assert_held to check for locks instead of an opencoded
> > variant.
> > 
> > Cc: aarcange@redhat.com
> > Signed-off-by: Andi Kleen <ak@linux.intel.com>
> > ---
> >  mm/huge_memory.c |    4 ++--
> >  mm/swap.c        |    2 +-
> >  2 files changed, 3 insertions(+), 3 deletions(-)
> > 
> > diff --git a/mm/huge_memory.c b/mm/huge_memory.c
> > index 91d3efb..28669c6 100644
> > --- a/mm/huge_memory.c
> > +++ b/mm/huge_memory.c
> > @@ -2083,7 +2083,7 @@ static void collect_mm_slot(struct mm_slot *mm_slot)
> >  {
> >  	struct mm_struct *mm = mm_slot->mm;
> >  
> > -	VM_BUG_ON(NR_CPUS != 1 && !spin_is_locked(&khugepaged_mm_lock));
> > +	lockdep_assert_held(&khugepaged_mm_lock);
> 
> This check was intended to be a VM debug check, so getting enabled by
> DEBUG_VM, not through lockdep. I mean I always have DEBUG_VM enabled
> in all my kernels, but lockdep only enabled on my test system. So it's
> not an opencoded variant strictly speaking.
> 
> My estimate is that what gets more tested is BUG_ON, second VM_BUG_ON,
> third LOCKDEP.

My estimate too.

> But hey, this code has been tested for a while so I'm
> neutral and if you prefer the lockdep version it's up to you.

Yes, it's not as if these are public interfaces used by drivers and
filesystems: they have very few callsites, and by now those lines
are mostly useful as documentation.

Andrew did mention assert_spin_locked() when I added those NR_CPUS
conditions, but we preferred VM_BUG_ON to BUG_ON, and I'm content
with Andi's further restriction to lockdep.

Acked-by: Hugh Dickins <hughd@google.com>

Hugh

  reply	other threads:[~2012-03-16 21:19 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-03-16 19:00 Tree sweep for spin_is_locked misuses and start warning about it Andi Kleen
2012-03-16 19:00 ` [PATCH 01/11] block: use lockdep_assert_held for queue locking Andi Kleen
2012-03-16 19:00 ` [PATCH 02/11] sgi-xp: Use lockdep_assert_held Andi Kleen
2012-03-16 19:11   ` Robin Holt
2012-03-16 19:00 ` [PATCH 03/11] ada152x: Remove broken usage of spin_is_locked Andi Kleen
2012-03-16 19:00 ` [PATCH 04/11] staging/zmem: Use lockdep_assert_held instead " Andi Kleen
2012-03-16 19:00 ` [PATCH 05/11] XFS: Fix lock ASSERT on UP Andi Kleen
2012-03-19 22:47   ` Dave Chinner
2012-03-20  2:28     ` Andi Kleen
2012-03-21  0:44       ` Dave Chinner
2012-03-16 19:00 ` [PATCH 06/11] huge-memory: Use lockdep_assert_held Andi Kleen
2012-03-16 19:44   ` Andrea Arcangeli
2012-03-16 21:18     ` Hugh Dickins [this message]
2012-03-16 19:01 ` [PATCH 07/11] futex: Use lockdep_assert_held() for lock checking Andi Kleen
2012-03-16 19:01 ` [PATCH 08/11] irda: remove spin_is_locked Andi Kleen
2012-03-16 19:01 ` [PATCH 09/11] usb: gadget: f_fs: Remove lock is held before freeing checks Andi Kleen
2012-03-16 19:01 ` [PATCH 10/11] smsc911x: Use lockdep_assert_held instead of home grown buggy construct Andi Kleen
2012-03-16 19:01 ` [PATCH 11/11] checkpatch: Check for spin_is_locked Andi Kleen
2012-03-16 19:22   ` Joe Perches
2012-03-16 20:14     ` Andi Kleen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LSU.2.00.1203161411160.1258@eggly.anvils \
    --to=hughd@google.com \
    --cc=aarcange@redhat.com \
    --cc=ak@linux.intel.com \
    --cc=andi@firstfloor.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®