From: Jan Engelhardt <jengelh@inai.de>
To: simran singhal <singhalsimran0@gmail.com>
Cc: wensong@linux-vs.org, Simon Horman <horms@verge.net.au>,
Julian Anastasov <ja@ssi.bg>,
Pablo Neira Ayuso <pablo@netfilter.org>,
Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>,
"David S. Miller" <davem@davemloft.net>,
netdev@vger.kernel.org, lvs-devel@vger.kernel.org,
netfilter-devel@vger.kernel.org, coreteam@netfilter.org,
linux-kernel@vger.kernel.org, outreachy-kernel@googlegroups.com
Subject: Re: [PATCH v2] netfilter: Clean up tests if NULL returned on failure
Date: Tue, 28 Mar 2017 15:54:40 +0200 (CEST) [thread overview]
Message-ID: <alpine.LSU.2.20.1703281552040.21255@n3.vanv.qr> (raw)
In-Reply-To: <20170328131340.GA19688@singhal-Inspiron-5558>
On Tuesday 2017-03-28 15:13, simran singhal wrote:
>Some functions like kmalloc/kzalloc return NULL on failure. When NULL
>represents failure, !x is commonly used.
>
>@@ -910,7 +910,7 @@ ip_vs_new_dest(struct ip_vs_service *svc, struct ip_vs_dest_user_kern *udest,
> }
>
> dest = kzalloc(sizeof(struct ip_vs_dest), GFP_KERNEL);
>- if (dest == NULL)
>+ if (!dest)
> return -ENOMEM;
This kind of transformation however is not cleanup anymore, it's really
bikeshedding and should be avoided. There are pro and cons for both
variants, and there is not really an overwhelming number of arguments
for either variant to justify the change.
next prev parent reply other threads:[~2017-03-28 14:04 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-03-28 13:13 simran singhal
2017-03-28 13:54 ` Jan Engelhardt [this message]
2017-03-28 16:23 ` SIMRAN SINGHAL
2017-03-29 6:55 ` Jan Engelhardt
2017-03-29 8:49 ` SIMRAN SINGHAL
2017-03-29 9:15 ` SIMRAN SINGHAL
2017-03-29 9:33 ` Jan Engelhardt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LSU.2.20.1703281552040.21255@n3.vanv.qr \
--to=jengelh@inai.de \
--cc=coreteam@netfilter.org \
--cc=davem@davemloft.net \
--cc=horms@verge.net.au \
--cc=ja@ssi.bg \
--cc=kadlec@blackhole.kfki.hu \
--cc=linux-kernel@vger.kernel.org \
--cc=lvs-devel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=netfilter-devel@vger.kernel.org \
--cc=outreachy-kernel@googlegroups.com \
--cc=pablo@netfilter.org \
--cc=singhalsimran0@gmail.com \
--cc=wensong@linux-vs.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®