From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-pl1-f175.google.com (mail-pl1-f175.google.com [209.85.214.175]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 8F0463385A1 for ; Wed, 22 Jul 2026 21:18:43 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.214.175 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1784755124; cv=none; b=AlHVcNssUpYlQnffL7HBs/H4EC7cQNxpz0/ciSTYktPyZoZ2LTf7QePYJbku0DVZ5rJkiIhxnty0hwdUh284RPCcIOyNJ/q8k5q3nZAEPz+pLNP2UPUNJSrMKgdALWriZZg09WRuKZUAYeUtlsV235KyyTGDNA5fB8IxYEnXHP0= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1784755124; c=relaxed/simple; bh=QTuY5fiA5djtL8cbl7MOKCbO6Q4G9M3hHh5OVXyo9Ss=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=nsCF/j9xNczbcD1fwkM/4nJAMAKkXo5UXwHWI6AX87Unanvdo8PPKGF6VFhliq1k+zlnH5CcR1Oc1YOhuhxtlhkGUQqzvylIEwnoZ632GkeCMqa81G+RgmMxIrc/9WffRRghtlvOOOc9hJrlymgqL7xyITcldSr6hPIpYfH8/6A= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=reject dis=none) header.from=google.com; spf=pass smtp.mailfrom=google.com; dkim=pass (2048-bit key) header.d=google.com header.i=@google.com header.b=MGT/4UaB; arc=none smtp.client-ip=209.85.214.175 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=reject dis=none) header.from=google.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=google.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=google.com header.i=@google.com header.b="MGT/4UaB" Received: by mail-pl1-f175.google.com with SMTP id d9443c01a7336-2cacef7d299so1125ad.1 for ; Wed, 22 Jul 2026 14:18:43 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=20251104; t=1784755123; x=1785359923; darn=vger.kernel.org; h=in-reply-to:content-disposition:content-type:mime-version :references:message-id:subject:cc:to:from:date:from:to:cc:subject :date:message-id:reply-to:content-type; bh=lqCXIznA1pzGDyUhZSlfjDm381k0hmycs7JYcnqQ7Fo=; b=MGT/4UaBlBjzzkoI+OwdyuxWryDp0InVk5r7xtNJPF4gOtbxrSFw/HmU9XIF1ttTLI S26YNi20xzRK0c10UOWm/RuJd1vsqWmCPNCKtaiUftTQyVu/uW9Zy+a+4be4DoUjyb+D /XlRQ20ZkxWppS29Jwr1cAYTVovnwTCEMDbigGL1bsEWgYh6iVBy5k7D0yVm1aRUdLa8 FoDpulI0oh8UoT4HwC+xL1P95QPt+xYyXE/iO2OEB5gJKVG5fNzFwHZZRRfUeY/LRvbF hlcPW12vjGMjLQ0R+CnW9BRz3hUEU5e76DiIvi8GmIHeKvrWVcNLcMHYrIDok5qxlEgB fosg== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1784755123; x=1785359923; h=in-reply-to:content-disposition:content-type:mime-version :references:message-id:subject:cc:to:from:date:x-gm-gg :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to :content-type; bh=lqCXIznA1pzGDyUhZSlfjDm381k0hmycs7JYcnqQ7Fo=; b=EVJjrwgyWqfuYtEUFT4kZsqPzPwRCMDZi7NSzzXYIN4+Jgl5ZuN2G62B24Nl/IQQGb jJS+LCwoiV6Uev2bfo3Da5WxWZe+VcN9j4UtdT85fbENlPsBkFTa/Be7TrGZh3QYVYkL VBlr1nrDIGNvgdP7bhlNOtArYyQSKH/IPMUg9NkyHscfswFXSu4s45Eih/Mi9thqy7hp iBopa6TGwpFwauKZkIebD0rCsvspcdj3wA8mi0PlbmqsXsdKH0Eh2v7ZGCNZZuDhxYi9 5bCUnNKy8zodA9pKTgKNQ8BggzCO89fscsvoYroq4l5ZLGvVmHh5rfMjcPV8EFxH/m0K kQyw== X-Forwarded-Encrypted: i=1; AHgh+RqiMkLP8cSL4mUejEbsW+fM9+zZkBB4oqZDsJM0n+RXrNAoO6/JlF5qFGOxldriL2R6ys3q4fdiLVtXBMo=@vger.kernel.org X-Gm-Message-State: AOJu0YyL6Tik9vY8lUrZx3Pkb68xDF5Dxw7JLz7EXEkPdVVrTavvC3tm pkGKCr3653pC5y8S0aKlmbA5ThCnK8jPK3SeOqc/wlmY+qx2dnuKFkFP+7Ear8E4Gg== X-Gm-Gg: AR+sD12ru3jo0kMPffoZtLoRCnVHQCPAvoGmmBZ4kuXRyO8uBA2VLuSHtO5McYyw2fl gZ5ABvlBomcB3DsCZo6NHfl40pIVIMksmJ2MDiXYyZYbRxLr9BmlZPSGf+JByVJGwuXDil6SEhI EZ1+Mm659oTOhGWUUzURxDwqz1KoJiKefJs7wtUMwzZ4Mquo7JhSC241B4sjK6o+cvaYE5bjfsJ LHqtmOpeYn4XwOf1d1y6OLp6mbKayxX/lfpOaoVNVEnMAW/TbpzsfFw2VoW8XypURG4/utK5uaR MULRFDX77+BNN7KPtlUCcXMXUIgk/X+MBfPMS0iY/ULIPGuaWuLB8DCMEo4X+2ApMNX2p6BtbcI jdgekn1Rx2wB+28vt7IwTyxmNzee3IM/F2QZyFLXHE+Oj5KnUI3jooZUIC0GE5Z1HT9QFJQ2opY C7zo1hseC68m6HKiVr/EDuFRDzdR0/4aCbf/gm X-Received: by 2002:a17:903:198c:b0:2ca:be81:b469 with SMTP id d9443c01a7336-2cfa422522fmr1806795ad.0.1784755122326; Wed, 22 Jul 2026 14:18:42 -0700 (PDT) Received: from google.com (10.129.124.34.bc.googleusercontent.com. [34.124.129.10]) by smtp.gmail.com with ESMTPSA id 5a478bee46e88-3147dc9f2f0sm13076614eec.13.2026.07.22.14.18.39 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Wed, 22 Jul 2026 14:18:41 -0700 (PDT) Date: Wed, 22 Jul 2026 21:18:35 +0000 From: Pranjal Shrivastava To: Mike Rapoport Cc: Pasha Tatashin , Pratyush Yadav , Alexander Graf , Samiullah Khawaja , David Matlack , kexec@lists.infradead.org, linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [RFC PATCH v2 1/2] kho: Introduce a helper to init unsplit pages Message-ID: References: <20260713204935.3069000-1-praan@google.com> <20260713204935.3069000-2-praan@google.com> <178456663513.143128.13731300065093148388.b4-review@b4> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <178456663513.143128.13731300065093148388.b4-review@b4> On Mon, Jul 20, 2026 at 07:57:15PM +0300, Mike Rapoport wrote: > > The current KHO restoration logic assumes all multi-page blocks are > > split into independent 4KB pages. Break out a helper to prepare for > > supporting high-order non-compound pages. > > > > Extract kho_init_unsplit_pages() to handle the refcount pattern > > where only the head page is refcounted. Use the helper for folio > > restoration that requires a similar refcount logic. > > > > Signed-off-by: Pranjal Shrivastava > > > > diff --git a/kernel/liveupdate/kexec_handover.c b/kernel/liveupdate/kexec_handover.c > > index 4834a809985ab..07f6f453cd69d 100644 > > --- a/kernel/liveupdate/kexec_handover.c > > +++ b/kernel/liveupdate/kexec_handover.c > > @@ -357,6 +357,24 @@ int kho_radix_walk_tree(struct kho_radix_tree *tree, > > } > > EXPORT_SYMBOL_GPL(kho_radix_walk_tree); > > > > +/* For physically contiguous pages. */ > > +static void kho_init_unsplit_pages(struct page *page, unsigned int order) > > +{ > > Can't say I like "unsplit". How about kho_init_high_order_page? > > And whatever name we pick here, it's surely must end with "page" rather > than "pages". > Ack. I'll rename this to kho_init_high_order_page(). Thanks, Praan