From: Jarkko Sakkinen <jarkko@kernel.org>
To: Kuldeep Singh <kuldeep.singh@oss.qualcomm.com>
Cc: Amirreza Zarrabi <amirreza.zarrabi@oss.qualcomm.com>,
Jens Wiklander <jenswi@kernel.org>,
Sumit Garg <sumit.garg@kernel.org>,
Peter Huewe <peterhuewe@gmx.de>, Jason Gunthorpe <jgg@ziepe.ca>,
linux-arm-msm@vger.kernel.org, op-tee@lists.trustedfirmware.org,
linux-kernel@vger.kernel.org, linux-integrity@vger.kernel.org
Subject: Re: [PATCH 2/2] firmware: tpm: Introduce tpm-qcom driver
Date: Wed, 9 Sep 2026 19:02:55 +0300 [thread overview]
Message-ID: <aqGDL2qZ0sZNMG0f@kernel.org> (raw)
In-Reply-To: <38984608-4b5c-4355-ad85-8c5a1fb78cb2@oss.qualcomm.com>
On Wed, Sep 02, 2026 at 02:52:17PM +0530, Kuldeep Singh wrote:
> On 01-09-2026 19:16, Jarkko Sakkinen wrote:
> > Short summary has a different driver name that is implemented i.e.,
> > it should has "tpm_qcom", not "tpm-qcom".
>
> True, let me make more generic like "Introduce Qualcomm TPM driver"
> instead of having driver filename in commit title for any confusion.
>
> >> MAINTAINERS | 7 +
> >> drivers/char/tpm/Kconfig | 9 ++
> >> drivers/char/tpm/Makefile | 1 +
> >> drivers/char/tpm/tpm_qcom.c | 371 ++++++++++++++++++++++++++++++++++++++++++++
> >> drivers/char/tpm/tpm_qcom.h | 82 ++++++++++
> >
> > Rename it as tpm_qcom_tee just to be aligned on how Microsoft's fTPM
> > driver is named.
>
> I'd say firstly microsoft ftpm driver should be renamed.
> For example, MS ftpm is based on optee(session based context) whereas
> Qcom tpm driver is based on qcomtee(part of same TEE subsystem but uses
> completely different mink-ipc based sharing mechanism).
> So, it's completely different driver compared to MS.
>
> My suggestions:
> - Rename MS driver i.e tpm_ftpm_tee.c -> tpm_microsoft.c
> - Rename Qcom driver i.e tpm_qcom.c -> tpm_qcom.c
This goes for argument using tpm_qcom.c but we don't rename ko's in
normal circumstances (unfortunately so).
>
> I see pattern like tpm_{loongson/atmel/ibm} etc. so better to follow
> this convention?
>
> If ever need optee/qtee to specify, more namings can be tpm_ftpm_optee.c
> and tpm_qcom_qtee.c?
> Personally, I don't prefer tpm_ftpm_tee.c as it's all generic name with
> no optee specification.
> >
> >> 5 files changed, 470 insertions(+)
> >>
> >> diff --git a/MAINTAINERS b/MAINTAINERS
> >> index 47b04968e79a..cfa5b66823c7 100644
> >> --- a/MAINTAINERS
> >> +++ b/MAINTAINERS
> >> @@ -22636,6 +22636,13 @@ S: Maintained
> >> F: Documentation/tee/qtee.rst
> >> F: drivers/tee/qcomtee/
> >>
> >> +QUALCOMM TPM DRIVER
> >> +M: Kuldeep Singh <kuldeep.singh@oss.qualcomm.com>
> >> +L: linux-arm-msm@vger.kernel.org
> >> +S: Maintained
> >> +F: drivers/char/tpm/tpm_qcom.c
> >> +F: drivers/char/tpm/tpm_qcom.h
> >> +
> >> QUALCOMM TRUST ZONE MEMORY ALLOCATOR
> >> M: Bartosz Golaszewski <brgl@kernel.org>
> >> L: linux-arm-msm@vger.kernel.org
> >
> > this change should be a separate patch.
>
> Ok, let me make MAINTAINERS entry as separate patch.
> Also, i noticed none of other driver are being even compiled as 'M' like
> atmel, ibm etc.
> Any obvious reason behind this?
> Should i enable tpm_qcom as Module in this patch only.
>
> >> + print_hex_dump_debug("tpm_qcom req: ", DUMP_PREFIX_OFFSET,
> >> + 16, 1, req, req_len, true);
> >
> > Please don't do this. It can put production systems at risk.
>
> Ok. I want to dump some contents on failures which makes debug easier.
> Instead of dumping entire req/rsp buffer, dump tag, reqlen, rsplen etc?
> >> +static struct tee_client_driver tpm_qcom_driver = {
> >> + .id_table = tpm_qcom_id_table,
> >> + .probe = tpm_qcom_probe,
> >> + .remove = tpm_qcom_remove,
> >> + .driver = {
> >> + .name = "tpm-qcom",
>
> Whatever naming we'll decide, I'll update same here too.
>
> >> +
> >> +/* dTPM SPI transfer optimization:
> >
> > Block comments AFAIK should be
> >
> > /*
> > * <TEXT>
> >
>
> Let me fix it.
>
> --
> Regards
> Kuldeep
>
BR, Jarkko
next prev parent reply other threads:[~2026-09-09 16:02 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-31 9:42 [PATCH 0/2] Add TPM support via Qualcomm TEE TPM TA Kuldeep Singh
2026-08-31 9:43 ` [PATCH 1/2] tee: qcomtee: Register qcom.tz.tpm service for discovery Kuldeep Singh
2026-09-02 9:27 ` Kuldeep Singh
2026-08-31 9:43 ` [PATCH 2/2] firmware: tpm: Introduce tpm-qcom driver Kuldeep Singh
2026-08-31 11:15 ` Konrad Dybcio
2026-08-31 11:26 ` Kuldeep Singh
2026-09-01 13:46 ` Jarkko Sakkinen
2026-09-02 9:22 ` Kuldeep Singh
2026-09-09 16:02 ` Jarkko Sakkinen [this message]
2026-09-10 8:34 ` Kuldeep Singh
2026-09-07 9:47 ` [PATCH 0/2] Add TPM support via Qualcomm TEE TPM TA Kuldeep Singh
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aqGDL2qZ0sZNMG0f@kernel.org \
--to=jarkko@kernel.org \
--cc=amirreza.zarrabi@oss.qualcomm.com \
--cc=jenswi@kernel.org \
--cc=jgg@ziepe.ca \
--cc=kuldeep.singh@oss.qualcomm.com \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-integrity@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=op-tee@lists.trustedfirmware.org \
--cc=peterhuewe@gmx.de \
--cc=sumit.garg@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®