mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Frank Li <Frank.li@oss.nxp.com>
To: Pawel Zalewski <pzalewski@thegoodpenguin.co.uk>
Cc: Viresh Kumar <vireshk@kernel.org>,
	Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Vinod Koul <vkoul@kernel.org>, Frank Li <Frank.Li@kernel.org>,
	Binbin Zhou <zhoubinbin@loongson.cn>,
	Sinan Kaya <okaya@kernel.org>,
	dmaengine@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-arm-msm@vger.kernel.org
Subject: Re: [PATCH v3 4/4] dmaengine: xgene-dma: use named initializers for acpi_device_id
Date: Wed, 16 Sep 2026 14:13:03 -0500	[thread overview]
Message-ID: <aqrqP9aHervoFsWy@SMW015318> (raw)
In-Reply-To: <20260916-acpi-dma-v3-4-0dac05654967@thegoodpenguin.co.uk>

On Wed, Sep 16, 2026 at 04:27:57PM +0100, Pawel Zalewski wrote:
> Use a designated initializer for the acpi_device_id fields which makes the
> code more readable and consistent with how lists are initialized in the
> rest of the kernel code base. Also drop explicitly setting fields to 0
> where it is redundant.
>
> Unify the list terminator to have a single space between the brackets and
> no trailing comma.
>
> Signed-off-by: Pawel Zalewski <pzalewski@thegoodpenguin.co.uk>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> ---

Reviewed-by: Frank Li <Frank.Li@nxp.com>

>  drivers/dma/xgene-dma.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/dma/xgene-dma.c b/drivers/dma/xgene-dma.c
> index fa1173e49900..8d1c58ca0d48 100644
> --- a/drivers/dma/xgene-dma.c
> +++ b/drivers/dma/xgene-dma.c
> @@ -1800,8 +1800,8 @@ static void xgene_dma_remove(struct platform_device *pdev)
>
>  #ifdef CONFIG_ACPI
>  static const struct acpi_device_id xgene_dma_acpi_match_ptr[] = {
> -	{"APMC0D43", 0},
> -	{},
> +	{ .id = "APMC0D43" },
> +	{ }
>  };
>  MODULE_DEVICE_TABLE(acpi, xgene_dma_acpi_match_ptr);
>  #endif
>
> --
> 2.43.0
>

      reply	other threads:[~2026-09-16 19:13 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-16 15:27 [PATCH v3 0/4] dmaengine: use designated " Pawel Zalewski
2026-09-16 15:27 ` [PATCH v3 1/4] dmaengine: dw: " Pawel Zalewski
2026-09-16 15:27 ` [PATCH v3 2/4] dmaengine: loongson: use named " Pawel Zalewski
2026-09-16 19:12   ` Frank Li
2026-09-16 15:27 ` [PATCH v3 3/4] dmaengine: qcom: " Pawel Zalewski
2026-09-16 19:12   ` Frank Li
2026-09-16 15:27 ` [PATCH v3 4/4] dmaengine: xgene-dma: " Pawel Zalewski
2026-09-16 19:13   ` Frank Li [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aqrqP9aHervoFsWy@SMW015318 \
    --to=frank.li@oss.nxp.com \
    --cc=Frank.Li@kernel.org \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=dmaengine@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=okaya@kernel.org \
    --cc=pzalewski@thegoodpenguin.co.uk \
    --cc=vireshk@kernel.org \
    --cc=vkoul@kernel.org \
    --cc=zhoubinbin@loongson.cn \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®