From: Wolfram Sang <wsa+renesas@sang-engineering.com>
To: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: linux-renesas-soc@vger.kernel.org, linux-kernel@vger.kernel.org,
Bjorn Andersson <andersson@kernel.org>,
Baolin Wang <baolin.wang@linux.alibaba.com>,
linux-remoteproc@vger.kernel.org
Subject: Re: [PATCH v7 3/3] hwspinlock: add low level debug capabilities
Date: Thu, 17 Sep 2026 11:10:23 +0200 [thread overview]
Message-ID: <aquufy5JW2Z5Gmq8@ninjato> (raw)
In-Reply-To: <CAMuHMdUPcBfFrLLW9_URM99S1jR-KhqUBQo1n7oHqX8qL4=1-w@mail.gmail.com>
[-- Attachment #1: Type: text/plain, Size: 877 bytes --]
> > You mean I should merge the two sentences into one?
>
> Yes, as the second "sentence" does not have a verb.
Pfff, okay.
> > > > + debugfs_create_file("request", 0200, rootdir, NULL, &fops_request);
> > > > + debugfs_create_file("free", 0200, rootdir, NULL, &fops_free);
> > > > + debugfs_create_file("lock", 0200, rootdir, NULL, &fops_trylock_raw);
> > > > + debugfs_create_file("unlock", 0200, rootdir, NULL, &fops_unlock_raw);
> > > > + debugfs_create_file("test_lock", 0200, rootdir, NULL, &fops_test);
> > >
> > > Perhaps just "test"?
> >
> > Hmm, too generic for my taste. In fact, I think I should maybe rename it
> > to "test_single_lock" to make it more precise...
>
> "test_single"? All others don't have "lock" in their name.
Hmm, I'd rather add 'lock' to request/free. Only lock_lock sounds
strange :)
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]
prev parent reply other threads:[~2026-09-17 9:10 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-12 19:14 [PATCH v7 0/3] hwspinlock: convert to XArray and add " Wolfram Sang
2026-09-12 19:14 ` [PATCH v7 1/3] hwspinlock: Convert to XArray Wolfram Sang
2026-09-12 19:14 ` [PATCH v7 2/3] hwspinlock: add list of locks to debugfs Wolfram Sang
2026-09-16 14:01 ` Geert Uytterhoeven
2026-09-16 14:16 ` Geert Uytterhoeven
2026-09-16 21:38 ` Wolfram Sang
2026-09-17 7:40 ` Geert Uytterhoeven
2026-09-17 9:08 ` Wolfram Sang
2026-09-16 21:40 ` Wolfram Sang
2026-09-17 7:44 ` Geert Uytterhoeven
2026-09-17 9:21 ` Wolfram Sang
2026-09-12 19:14 ` [PATCH v7 3/3] hwspinlock: add low level debug capabilities Wolfram Sang
2026-09-16 14:11 ` Geert Uytterhoeven
2026-09-16 21:44 ` Wolfram Sang
2026-09-17 8:10 ` Geert Uytterhoeven
2026-09-17 9:10 ` Wolfram Sang [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aquufy5JW2Z5Gmq8@ninjato \
--to=wsa+renesas@sang-engineering.com \
--cc=andersson@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=geert@linux-m68k.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®