From: Daniel Golle <daniel@makrotopia.org>
To: Caleb James DeLisle <cjd@cjdns.fr>
Cc: netdev@vger.kernel.org, dqfext@gmail.com,
SkyLake.Huang@mediatek.com, andrew@lunn.ch, hkallweit1@gmail.com,
linux@armlinux.org.uk, davem@davemloft.net, edumazet@google.com,
kuba@kernel.org, pabeni@redhat.com, matthias.bgg@gmail.com,
angelogioacchino.delregno@collabora.com,
linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-mediatek@lists.infradead.org,
Matheus Sampaio Queiroga <srherobrine20@gmail.com>
Subject: Re: [PATCH v5 net-next] net: phy: mediatek: support MT7530 PHYs on EN71221 MCM
Date: Thu, 17 Sep 2026 20:21:10 +0100 [thread overview]
Message-ID: <aqw9ptzAZBmdHy1S@makrotopia.org> (raw)
In-Reply-To: <95202df5-fdbb-4325-b77b-5f45ac8b1732@cjdns.fr>
On Thu, Sep 17, 2026 at 05:11:50PM +0200, Caleb James DeLisle wrote:
>
> On 17/09/2026 16:48, Daniel Golle wrote:
> > On Tue, Sep 15, 2026 at 02:01:29PM +0200, Caleb James DeLisle wrote:
> > > On 15/09/2026 13:47, Daniel Golle wrote:
> > > > On Tue, Sep 15, 2026 at 11:34:27AM +0000, Caleb James DeLisle wrote:
> > > > > @@ -135,6 +199,23 @@ static struct phy_driver mtk_gephy_driver[] = {
> > > > > */
> > > > > .config_intr = genphy_no_config_intr,
> > > > > .handle_interrupt = genphy_handle_interrupt_no_ack,
> > > > > + .match_phy_device = mt7530_phy_match,
> > > > > + .suspend = genphy_suspend,
> > > > > + .resume = genphy_resume,
> > > > > + .read_page = mtk_phy_read_page,
> > > > > + .write_page = mtk_phy_write_page,
> > > > > + },
> > > > > + {
> > > > > + PHY_ID_MATCH_EXACT(MTK_GPHY_ID_MT7530),
> > > > I'd suggest to actually use phy_id and phy_id_mask assigned by the
> > > > PHY_ID_MATCH_EXACT macro by calling genphy_match_phy_device() in your
> > > > match functions above instead of open-coding the ID match.
> > > > Or drop PHY_ID_MATCH_EXACT from *both* drivers.
> > > I suppose the latter is easier because then I don't have to re-think
> > > mt7530_is_gphy() which would be lying if it wasn't actually checking ID is
> > > MTK_GPHY_ID_MT7530.
> > >
> > I would have preferred to call genphy_match_phy_device() in your match
> > functions instead of open-coding phy_id_compare() which is best
> > reached via genphy_match_phy_device() in this situation -- that would
> > express the code intent in the most obvious way imho.
>
>
> I did it this way because the name mt7530_is_gphy() implies "Is this an
> MT7530 gigabit PHY?" which if it doesn't match on MTK_GPHY_ID_MT7530 then
> that's not what it does so there's a little bit more thought involved.
>
>
> If I'd have known this was really your preference I'd have done that, but I
> already just sent v6 so I guess I can send v7 tomorrow.
It's also fine for me like it is now, just a light preference, not
worth a resend just for that.
However, I'd also still like to see the OF parent walk replaced by
register evidence, which requires that you dump the registers more
than once to understand if any difference are things like counters or
temperature, or actually identify the PHY variant.
It can of course be that the actual silicon is really the exact same
MT7530 MCM as eg. on MT7623, just driven by a different clock
frequency and the observable register differences are things like
clock devidors -- if we manage to understand that and just apply the
resulting tuning accordingly, even better.
next prev parent reply other threads:[~2026-09-17 19:21 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-15 11:34 Caleb James DeLisle
2026-09-15 11:47 ` Daniel Golle
2026-09-15 12:01 ` Caleb James DeLisle
2026-09-17 14:48 ` Daniel Golle
2026-09-17 15:11 ` Caleb James DeLisle
2026-09-17 19:21 ` Daniel Golle [this message]
2026-09-17 20:54 ` Caleb James DeLisle
2026-09-16 12:19 ` netdev-bot+sashiko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aqw9ptzAZBmdHy1S@makrotopia.org \
--to=daniel@makrotopia.org \
--cc=SkyLake.Huang@mediatek.com \
--cc=andrew@lunn.ch \
--cc=angelogioacchino.delregno@collabora.com \
--cc=cjd@cjdns.fr \
--cc=davem@davemloft.net \
--cc=dqfext@gmail.com \
--cc=edumazet@google.com \
--cc=hkallweit1@gmail.com \
--cc=kuba@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux@armlinux.org.uk \
--cc=matthias.bgg@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=srherobrine20@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®