From: Leonardo Martins Martins <dev.lmmrtns@gmail.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/3] staging: rtl8723bs: rename local vars in phy_tx_power_limit_to_index()
Date: Fri, 2 Oct 2026 04:30:27 -0300 [thread overview]
Message-ID: <ar9dk-Ja8tqS7ufC@debian> (raw)
In-Reply-To: <2026100258-probing-reactive-1191@gregkh>
On Fri, Oct 02, 2026 at 08:09:28AM +0200, Greg Kroah-Hartman wrote:
> On Fri, Oct 02, 2026 at 01:07:35AM -0300, Leonardo Martins Martins wrote:
> > In phy_tx_power_limit_to_index(), there are many mixed-case local
> > variables, rename them to adhere to the linux kernel coding style.
> >
> > Signed-off-by: Leonardo Martins Martins <dev.lmmrtns@gmail.com>
> > ---
> > Renamed Variables:
> > pHalData -> hal_data
> > Adapter -> adapter
> > BW40PwrBasedBm2_4G -> pwr_base
>
> "power_base"?
Yeah power_base does seem better.
>
> > rateSection -> rs
>
> What's wrong with "rate_selection"? We have lots of characters you can
> use :)
Here I used rs instead of rate_section because I saw it being used
like that in rtw88, and I also saw the "Naming" section of
Documentation/process/coding-style.rst where it says local variable
names should be short and to the point.
Regardless, I don't have any strong opinions on these variable names,
rate_section is also fine, so I'll just use that in v3.
>
> > tempValue -> tmp
> > tempPwrLmt -> tmp_pwr_lmt
> > rfPath -> path
>
> Why isn't this in the changelog text?
Oh it really should be, my bad.
Best Regards,
Leonardo Martins
next prev parent reply other threads:[~2026-10-02 7:30 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-10-02 4:07 [PATCH v2 0/3] staging: rtl8723bs: refactor PHY_ConvertTxPowerLimitToPowerIndex() Leonardo Martins Martins
2026-10-02 4:07 ` [PATCH v2 1/3] staging: rtl8723bs: rename local vars in phy_tx_power_limit_to_index() Leonardo Martins Martins
2026-10-02 6:09 ` Greg Kroah-Hartman
2026-10-02 7:30 ` Leonardo Martins Martins [this message]
2026-10-02 4:07 ` [PATCH v2 2/3] staging: rtl8723bs: access TxPowerByRateBase2_4G directly Leonardo Martins Martins
2026-10-02 4:07 ` [PATCH v2 3/3] staging: rtl8723bs: extract inner loop in phy_tx_power_limit_to_index() Leonardo Martins Martins
2026-10-02 6:10 ` [PATCH v2 0/3] staging: rtl8723bs: refactor PHY_ConvertTxPowerLimitToPowerIndex() Greg Kroah-Hartman
2026-10-02 7:39 ` Leonardo Martins Martins
2026-10-02 7:55 ` Greg Kroah-Hartman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ar9dk-Ja8tqS7ufC@debian \
--to=dev.lmmrtns@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®