From: Kairui Song <ryncsn@gmail.com>
To: "David Hildenbrand (Arm)" <david@kernel.org>
Cc: kasong@tencent.com, linux-mm@kvack.org,
linux-kernel@vger.kernel.org,
Andrew Morton <akpm@linux-foundation.org>,
Lorenzo Stoakes <ljs@kernel.org>, Zi Yan <ziy@nvidia.com>,
Baolin Wang <baolin.wang@linux.alibaba.com>,
"Liam R. Howlett" <liam@infradead.org>,
Nico Pache <nico.pache@linux.dev>,
Ryan Roberts <ryan.roberts@arm.com>, Dev Jain <dev.jain@arm.com>,
Lance Yang <lance.yang@linux.dev>,
Usama Arif <usama.arif@linux.dev>,
Vlastimil Babka <vbabka@kernel.org>,
Mike Rapoport <rppt@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>, Chris Li <chrisl@kernel.org>,
Kemeng Shi <shikemeng@huaweicloud.com>,
Nhat Pham <nphamcs@gmail.com>, Baoquan He <baoquan.he@linux.dev>,
Barry Song <baohua@kernel.org>,
Youngjun Park <youngjun.park@lge.com>,
Yeoreum Yun <yeoreum.yun@arm.com>,
"Kiryl Shutsemau (Meta)" <kas@kernel.org>,
Shivam Kalra <shivamkalra98@zohomail.in>
Subject: Re: [PATCH v5 09/17] mm/huge_memory: rename remap_page() to remap_anon_folio()
Date: Wed, 23 Sep 2026 14:21:08 +0200 [thread overview]
Message-ID: <arPD3ztCpw0r0mBu@KASONG-MC4> (raw)
In-Reply-To: <6e542162-fe6c-47da-b0c4-a36251242950@kernel.org>
On Fri, Sep 18, 2026 at 10:46:55PM +0100, David Hildenbrand (Arm) wrote:
> On 9/14/26 19:14, Kairui Song via B4 Relay wrote:
> > From: Kairui Song <kasong@tencent.com>
> >
> > remap_page() now only has one caller, __folio_freeze_split_anon(),
> > and is only ever called for anon folios: unmap_folio() currently
> > leaves file folios unmapped after the split, so they need no
> > remapping.
> >
> > Rename it to remap_anon_folio() to make that explicit, and add a
> > VM_WARN_ON_FOLIO() documenting it.
> >
> > Reviewed-by: Zi Yan <ziy@nvidia.com>
> > Reviewed-by: Kiryl Shutsemau (Meta) <kas@kernel.org>
> > Signed-off-by: Kairui Song <kasong@tencent.com>
> > ---
> > mm/huge_memory.c | 17 ++++++++++++-----
> > 1 file changed, 12 insertions(+), 5 deletions(-)
> >
> > diff --git a/mm/huge_memory.c b/mm/huge_memory.c
> > index 1749905ade6a..77bf68c9b9af 100644
> > --- a/mm/huge_memory.c
> > +++ b/mm/huge_memory.c
> > @@ -3552,7 +3552,7 @@ static void unmap_folio(struct folio *folio)
> > /*
> > * Anon pages need migration entries to preserve them, but file
> > * pages can simply be left unmapped, then faulted back on demand.
> > - * If that is ever changed (perhaps for mlock), update remap_page().
> > + * If that is ever changed (perhaps for mlock), update remap_anon_folio().
>
> See my comment below, delete that comment about "what if X" entirely. Also, we
> wouldn't want to update remap_anon_folio().
Sure, it was added due to some previous reviews, but things are cleaner
now with the renaming so just remove it is indeed better.
...
>
> Add remap_anon_folio for file folios? Just delete this entire code comment.
> Whoever wants to implement that can look into the pieces that are actually needed.
>
>
> With the comments sorted
Thanks!
next prev parent reply other threads:[~2026-09-23 12:21 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-14 17:14 [PATCH v5 00/17] mm/huge_memory: clean up and decouple the anon and file split helpers Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 01/17] mm/swap: fix off-by-one in swap cache replace sanity check Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 02/17] mm/huge_memory: fix rejection of swap cache folios with a mapping Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 03/17] mm/huge_memory: invert folio_ref_freeze() check to reduce indentation Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 04/17] mm/huge_memory: split the routine for splitting anon and file folio Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 05/17] mm/huge_memory: rename __split_unmapped_folio() to __split_frozen_folio() Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 06/17] mm/huge_memory: consolidate irq and locking for folio split Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 07/17] mm/huge_memory: move EOF trimming into the file split helper Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 08/17] mm/huge_memory: move unmap and remap into the split helpers Kairui Song via B4 Relay
2026-09-18 20:48 ` David Hildenbrand (Arm)
2026-09-14 17:14 ` [PATCH v5 09/17] mm/huge_memory: rename remap_page() to remap_anon_folio() Kairui Song via B4 Relay
2026-09-14 17:28 ` Yeoreum Yun
2026-09-18 20:46 ` David Hildenbrand (Arm)
2026-09-23 12:21 ` Kairui Song [this message]
2026-09-14 17:14 ` [PATCH v5 10/17] mm/huge_memory: move the racy refcount check into unmap_folio() Kairui Song via B4 Relay
2026-09-14 17:29 ` Yeoreum Yun
2026-09-18 20:53 ` David Hildenbrand (Arm)
2026-09-14 17:14 ` [PATCH v5 11/17] mm/huge_memory: move filemap management into the file split helper Kairui Song via B4 Relay
2026-09-14 17:30 ` Yeoreum Yun
2026-09-18 20:57 ` David Hildenbrand (Arm)
2026-09-14 17:14 ` [PATCH v5 12/17] mm/huge_memory: move anon_vma handling into the anon " Kairui Song via B4 Relay
2026-09-14 17:27 ` Yeoreum Yun
2026-09-18 21:02 ` David Hildenbrand (Arm)
2026-09-14 17:14 ` [PATCH v5 13/17] mm/huge_memory: move memcg switch into the file " Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 14/17] mm/huge_memory: drop the unused do_lru argument of " Kairui Song via B4 Relay
2026-09-14 17:14 ` [PATCH v5 15/17] mm/huge_memory: clean up after-split folio freeing in __folio_split Kairui Song via B4 Relay
2026-09-18 21:03 ` David Hildenbrand (Arm)
2026-09-14 17:14 ` [PATCH v5 16/17] mm/huge_memory: count only swap cache refs in anon folio split Kairui Song via B4 Relay
2026-09-18 21:07 ` David Hildenbrand (Arm)
2026-09-14 17:14 ` [PATCH v5 17/17] mm/huge_memory: drop the redundant mapping argument of __split_frozen_folio Kairui Song via B4 Relay
2026-09-18 21:04 ` David Hildenbrand (Arm)
2026-09-15 0:45 ` [PATCH v5 00/17] mm/huge_memory: clean up and decouple the anon and file split helpers Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=arPD3ztCpw0r0mBu@KASONG-MC4 \
--to=ryncsn@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=baoquan.he@linux.dev \
--cc=chrisl@kernel.org \
--cc=david@kernel.org \
--cc=dev.jain@arm.com \
--cc=kas@kernel.org \
--cc=kasong@tencent.com \
--cc=lance.yang@linux.dev \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@suse.com \
--cc=nico.pache@linux.dev \
--cc=nphamcs@gmail.com \
--cc=rppt@kernel.org \
--cc=ryan.roberts@arm.com \
--cc=shikemeng@huaweicloud.com \
--cc=shivamkalra98@zohomail.in \
--cc=surenb@google.com \
--cc=usama.arif@linux.dev \
--cc=vbabka@kernel.org \
--cc=yeoreum.yun@arm.com \
--cc=youngjun.park@lge.com \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®