From: Kiryl Shutsemau <kirill@shutemov.name>
To: "David Hildenbrand (Arm)" <david@kernel.org>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Lorenzo Stoakes <ljs@kernel.org>, Zi Yan <ziy@nvidia.com>,
Baolin Wang <baolin.wang@linux.alibaba.com>,
linux-mm@kvack.org, linux-kernel@vger.kernel.org,
kernel-team@meta.com, "Liam R. Howlett" <liam@infradead.org>,
Nico Pache <nico.pache@linux.dev>,
Ryan Roberts <ryan.roberts@arm.com>, Dev Jain <dev.jain@arm.com>,
Barry Song <baohua@kernel.org>,
Lance Yang <lance.yang@linux.dev>,
Usama Arif <usama.arif@linux.dev>,
Vlastimil Babka <vbabka@kernel.org>,
Jann Horn <jannh@google.com>
Subject: Re: [PATCH v3 08/12] mm/collapse: separate scanning a PTE table from collapsing it
Date: Thu, 24 Sep 2026 15:19:30 +0100 [thread overview]
Message-ID: <arUrhkCjop-htTZh@thinkstation> (raw)
In-Reply-To: <ebf8972a-0c92-41c4-9f42-22ffb820d07a@kernel.org>
On Wed, Sep 23, 2026 at 03:04:05PM +0200, David Hildenbrand (Arm) wrote:
> On 9/16/26 11:31, Kiryl Shutsemau wrote:
> > From: "Kiryl Shutsemau (Meta)" <kas@kernel.org>
> >
> > A collapse is two jobs. One reads a PTE table under mmap_lock and decides
> > whether the range is worth collapsing. The other allocates, isolates,
> > copies and flushes, and wants the lock given up first.
> >
> > collapse_single_pmd() did both, so the boundary between them was somewhere
> > in the middle of a function.
> >
> > Give each half its own function:
> >
> > - collapse_scan_pmd() scans one table and only reads. The anonymous
> > scan that used to carry that name keeps its body as
> > collapse_scan_anon_pmd(), and collapse_scan_pmd() is now the entry
> > that picks the anonymous or the file side.
> >
> > - collapse_run_pmd() does the collapse the scan asked for, and is
> > handed what the scan returned. SCAN_SUCCEED means there is
> > something to collapse. SCAN_PTE_MAPPED_HUGEPAGE means the page
> > cache already holds the PMD folio and only the PTE table is left to
> > retract. Both are work for the run; anything else is why there is
> > nothing to do.
>
> Makes sense.
>
> The naming is a bit suboptimal and inconsistent.
>
> collapse_single_pmd
> -> collapse_scan_pmd()
> -> collapse_run_pmd()
>
> Maybe it would be clearer:
>
> collapse_pmd() ["single" is rather useless]
> -> collapse_scan_pmd()
> -> collapse_scanned_pmd()
Yes, the naming is awkward.
The problem is that collapse_ is the prefix of everything in the
interface, so it cannot double as the verb: collapse_pmd() says what the
function is about, not what it does, and collapse_scanned_pmd() has no
verb at all.
Each name needs one after the prefix, hence scan and run. I don't
particularly like it, but it seems better than scan and scanned, no?
collapse_single_pmd() itself goes away in the next patch. You asked
there why; I will answer there.
> > What the scan found and the run needs travels in collapse_control. For
> > an anonymous table that is the orders and the referenced and swapped-out
> > counts, which mthp_collapse() and collapse_huge_page() now read from
> > there instead of taking as arguments. For a file it is the file itself
> > and the offset in it.
> >
> > The file side moves with the anonymous one. collapse_scan_file() used to
> > run with mmap_lock already given up, and called collapse_file() itself
> > when the page cache looked worth it. It now runs under the lock like the
> > anonymous scan and only reads; the run does the collapse.
>
> So we add more locking to the file path to merge both paths cleanly? Or did I
> misunderstand that paragraph?
The lock is held over the scan now, but it is taken fewer times. The
current code drops mmap_lock before the file scan, before it knows if
there is anything to collapse. Most scans find nothing, and each of them
pays the cost of unlock and relock for nothing.
Dropping the lock only after a scan found work mirrors the anonymous
side, with the same batching shape.
> What do you mean with "and only reads"?
That it no longer calls collapse_file(). The scan looks at the page
cache and says whether there is work; collapse_file() is the run's job.
I will drop the wording. It does not help.
> > A file
> > collapse works on the page cache and never sees a VMA, so the scan takes
> > the file reference while it still has one and the run gives it back.
> >
> > That changes what a refused file table costs khugepaged. Every file
> > table it scanned used to end its pass over that mm, because the lock had
> > been dropped to scan it; now only a table it goes on to collapse does.
>
> The last sentence makes no sense. At least to me :)
It is also wrong, so I will rewrite it.
Before this patch collapse_single_pmd() set lock_dropped for every file
table, refused or not, and collapse_scan_mm_slot() bailed out on it.
The mm slot stays, so the next call comes back to the same mm at the
saved address, but every file table cost an unlock, a trip through
khugepaged_do_scan(), a relock and a VMA lookup.
Now only a table that gets collapsed pays that.
> > Two things on the file side stop being rescanned. When the page cache
> > already holds the PMD folio, the scan says so and the run goes straight
> > to retracting the PTE table. A run that refuses dirty pages and may
> > write them back retries collapse_file() alone. The checks the scan makes
> > ahead of it are ones collapse_file() repeats under the page cache lock.
>
> Is there any way we could move these changes into separate patches? These
> changes are bit squeezed into the last part of this description. And having to
> much happening at once makes this rather hard to grasp.
Ack.
> > Tracing changes with it. mm_khugepaged_scan_pmd and
> > mm_khugepaged_scan_file used to fire after the collapse, so for an
> > accepted table their status field carried what the collapse made of it.
> > They now fire before it and read SCAN_SUCCEED for an accepted table. What
> > the collapse then made of it is for mm_collapse_huge_page and
> > mm_khugepaged_collapse_file to report.
> >
> > Assisted-by: LLM
> > Reviewed-by: Zi Yan <ziy@nvidia.com>
> > Signed-off-by: Kiryl Shutsemau (Meta) <kas@kernel.org>
> > ---
> > mm/collapse.h | 14 ++++
> > mm/khugepaged.c | 166 +++++++++++++++++++++++++++++++++---------------
> > 2 files changed, 130 insertions(+), 50 deletions(-)
>
> [...]
>
> > -/*
> > - * Try to collapse a single PMD starting at a PMD aligned addr, and return
> > - * the results.
> > - */
> > -static enum scan_result collapse_single_pmd(unsigned long addr,
> > - struct vm_area_struct *vma, bool *lock_dropped,
> > - struct collapse_control *cc)
> > +static void collapse_control_init(struct collapse_control *cc)
> > +{
> > + cc->progress = 0;
> > + cc->scan_file = NULL;
> > +}
> > +
> > +/* A scan that took a file reference should have been run */
> > +static void collapse_put_scan_file(struct collapse_control *cc)
> > +{
> > + if (WARN_ON_ONCE(cc->scan_file)) {
> > + fput(cc->scan_file);
> > + cc->scan_file = NULL;
> > + }
>
> See below regarding _release: having _put functions that are not supposed to put
> anything except with BUG is akward.
>
> > +}
> > +
> > +static void collapse_control_release(struct collapse_control *cc)
> > +{
> > + collapse_put_scan_file(cc);
> > +}
>
> Do we really have to introduce collapse_control_release() just to perform some
> safety checks for BUGs? I'd rather keep the collapse interface minimal and not
> introduce _release semantics when there is actually nothing to be released?
>
> Or will you add more into _release in later patches in this series?
Not in this series.
The engine I have on top of it gives both a job.
I will drop it from this series and add it with the engine. The shape
might change by the time the engine is posted.
The check at the top of collapse_scan_pmd() stays, open-coded: a scan
that found work on a file table holds a reference, and the next scan is
where one that was never run gets caught.
--
Kiryl Shutsemau / Kirill A. Shutemov
next prev parent reply other threads:[~2026-09-24 14:19 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-16 9:31 [PATCH v3 00/12] mm/collapse: separate a collapse from its callers Kiryl Shutsemau
2026-09-16 9:31 ` [PATCH v3 01/12] mm/khugepaged: drop redundant mm_struct pin in madvise_collapse() Kiryl Shutsemau
2026-09-23 11:49 ` David Hildenbrand (Arm)
2026-09-16 9:31 ` [PATCH v3 02/12] mm/khugepaged: count collapses where khugepaged makes them Kiryl Shutsemau
2026-09-23 11:51 ` David Hildenbrand (Arm)
2026-09-16 9:31 ` [PATCH v3 03/12] mm/khugepaged: rename mthp_present_ptes bitmap to eligible_ptes Kiryl Shutsemau
2026-09-23 11:52 ` David Hildenbrand (Arm)
2026-09-16 9:31 ` [PATCH v3 04/12] mm/collapse: add collapse.h for the collapse interface Kiryl Shutsemau
2026-09-23 11:56 ` David Hildenbrand (Arm)
2026-09-16 9:31 ` [PATCH v3 05/12] mm/collapse: state what a collapse may do in the policy Kiryl Shutsemau
2026-09-23 12:24 ` David Hildenbrand (Arm)
2026-09-24 13:49 ` Kiryl Shutsemau
2026-09-16 9:31 ` [PATCH v3 06/12] mm/collapse: drop the collapse_possible() wrapper Kiryl Shutsemau
2026-09-23 12:25 ` David Hildenbrand (Arm)
2026-09-16 9:31 ` [PATCH v3 07/12] mm/collapse: name the per-table scan reset for what it resets Kiryl Shutsemau
2026-09-23 12:26 ` David Hildenbrand (Arm)
2026-09-16 9:31 ` [PATCH v3 08/12] mm/collapse: separate scanning a PTE table from collapsing it Kiryl Shutsemau
2026-09-18 9:06 ` Baolin Wang
2026-09-23 13:04 ` David Hildenbrand (Arm)
2026-09-24 14:19 ` Kiryl Shutsemau [this message]
2026-09-16 9:31 ` [PATCH v3 09/12] mm/collapse: open-code collapse_single_pmd() in its two callers Kiryl Shutsemau
2026-09-18 9:31 ` Baolin Wang
2026-09-23 13:08 ` David Hildenbrand (Arm)
2026-09-24 14:56 ` Kiryl Shutsemau
2026-09-16 9:31 ` [PATCH v3 10/12] mm/collapse: work out the orders a VMA allows once per VMA Kiryl Shutsemau
2026-09-23 13:19 ` David Hildenbrand (Arm)
2026-09-24 15:04 ` Kiryl Shutsemau
2026-09-16 9:31 ` [PATCH v3 11/12] mm/collapse: declare the collapse interface in collapse.h Kiryl Shutsemau
2026-09-23 13:34 ` David Hildenbrand (Arm)
2026-09-24 15:22 ` Kiryl Shutsemau
2026-09-16 9:31 ` [PATCH v3 12/12] mm/collapse: implement MADV_COLLAPSE in madvise.c Kiryl Shutsemau
2026-09-16 22:48 ` [PATCH v3 00/12] mm/collapse: separate a collapse from its callers Andrew Morton
2026-09-17 12:26 ` Kiryl Shutsemau
2026-09-17 22:11 ` Andrew Morton
2026-09-23 13:52 ` David Hildenbrand (Arm)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=arUrhkCjop-htTZh@thinkstation \
--to=kirill@shutemov.name \
--cc=akpm@linux-foundation.org \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=david@kernel.org \
--cc=dev.jain@arm.com \
--cc=jannh@google.com \
--cc=kernel-team@meta.com \
--cc=lance.yang@linux.dev \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=nico.pache@linux.dev \
--cc=ryan.roberts@arm.com \
--cc=usama.arif@linux.dev \
--cc=vbabka@kernel.org \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®