From: "Alvin Šipraga" <alvin.sipraga@analog.com>
To: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Cc: Linus Walleij <linusw@kernel.org>, Andrew Lunn <andrew@lunn.ch>,
Vladimir Oltean <olteanv@gmail.com>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@kernel.org>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
netdev@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH net-next] net: dsa: realtek: rtl8365mb: define masks using BIT() and GENMASK()
Date: Sat, 3 Oct 2026 13:27:26 +0200 [thread overview]
Message-ID: <asDmigQLCrVQSioU@analog.com> (raw)
In-Reply-To: <20261002-realtek_bit-v1-1-771fb0e39083@gmail.com>
On Fri, Oct 02, 2026 at 11:14:57AM -0300, Luiz Angelo Daros de Luca wrote:
> Refactor register bitmask definitions to use the standard BIT() and
> GENMASK() macros instead of hardcoded hexadecimal values. This improves
> code readability, reducing the chance of errors such as unintentional
> gaps or overlaps.
>
> Introduce RTL8365MB_PORT_MASK as an alias for GENMASK(10, 0) to replace
> the repetitive 0x07FF values used across various port-related bitfields.
>
> This is a pure refactoring patch; no functional changes are introduced.
>
> Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Reviewed-by: Alvin Šipraga <alvin.sipraga@analog.com>
> ---
> drivers/net/dsa/realtek/rtl8365mb_main.c | 168 ++++++++++++++++---------------
> drivers/net/dsa/realtek/rtl8365mb_vlan.c | 4 +-
> 2 files changed, 87 insertions(+), 85 deletions(-)
prev parent reply other threads:[~2026-10-03 11:27 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-10-02 14:14 Luiz Angelo Daros de Luca
2026-10-03 11:27 ` Alvin Šipraga [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=asDmigQLCrVQSioU@analog.com \
--to=alvin.sipraga@analog.com \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@kernel.org \
--cc=kuba@kernel.org \
--cc=linusw@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luizluca@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=olteanv@gmail.com \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®