From: Saeed Mahameed <saeedm@nvidia.com>
To: "davidcomponentone@gmail.com" <davidcomponentone@gmail.com>
Cc: "linux-rdma@vger.kernel.org" <linux-rdma@vger.kernel.org>,
"zealci@zte.com.cn" <zealci@zte.com.cn>,
"davem@davemloft.net" <davem@davemloft.net>,
Roi Dayan <roid@nvidia.com>, Ariel Levkovich <lariel@nvidia.com>,
Paul Blakey <paulb@nvidia.com>, Vlad Buslov <vladbu@nvidia.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
Chris Mi <cmi@nvidia.com>, "kuba@kernel.org" <kuba@kernel.org>,
"netdev@vger.kernel.org" <netdev@vger.kernel.org>,
"leon@kernel.org" <leon@kernel.org>, Oz Shlomo <ozsh@nvidia.com>,
"yang.guang5@zte.com.cn" <yang.guang5@zte.com.cn>
Subject: Re: [PATCH] net/mlx5: use swap() to make code cleaner
Date: Tue, 16 Nov 2021 20:56:33 +0000 [thread overview]
Message-ID: <b09fae8a2ac505b302047cbb5a17be05d7da3302.camel@nvidia.com> (raw)
In-Reply-To: <20211104011737.1028163-1-yang.guang5@zte.com.cn>
On Thu, 2021-11-04 at 09:17 +0800, davidcomponentone@gmail.com wrote:
> From: Yang Guang <yang.guang5@zte.com.cn>
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
>
> Reported-by: Zeal Robot <zealci@zte.com.cn>
> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
> ---
> drivers/net/ethernet/mellanox/mlx5/core/en/tc_ct.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlx5/core/en/tc_ct.c
> b/drivers/net/ethernet/mellanox/mlx5/core/en/tc_ct.c
> index c1c6e74c79c4..8ce4b6112169 100644
> --- a/drivers/net/ethernet/mellanox/mlx5/core/en/tc_ct.c
> +++ b/drivers/net/ethernet/mellanox/mlx5/core/en/tc_ct.c
> @@ -907,12 +907,9 @@ mlx5_tc_ct_shared_counter_get(struct
> mlx5_tc_ct_priv *ct_priv,
> struct mlx5_ct_tuple rev_tuple = entry->tuple;
> struct mlx5_ct_counter *shared_counter;
> struct mlx5_ct_entry *rev_entry;
> - __be16 tmp_port;
>
> /* get the reversed tuple */
> - tmp_port = rev_tuple.port.src;
> - rev_tuple.port.src = rev_tuple.port.dst;
> - rev_tuple.port.dst = tmp_port;
> + swap(rev_tuple.port.src, rev_tuple.port.dst);
>
> if (rev_tuple.addr_type == FLOW_DISSECTOR_KEY_IPV4_ADDRS) {
> __be32 tmp_addr = rev_tuple.ip.src_v4;
An identical patch was already submitted the day before.
Thanks for the effort !
prev parent reply other threads:[~2021-11-16 20:56 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-11-04 1:17 davidcomponentone
2021-11-04 5:26 ` Saeed Mahameed
2021-11-16 20:56 ` Saeed Mahameed [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b09fae8a2ac505b302047cbb5a17be05d7da3302.camel@nvidia.com \
--to=saeedm@nvidia.com \
--cc=cmi@nvidia.com \
--cc=davem@davemloft.net \
--cc=davidcomponentone@gmail.com \
--cc=kuba@kernel.org \
--cc=lariel@nvidia.com \
--cc=leon@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rdma@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=ozsh@nvidia.com \
--cc=paulb@nvidia.com \
--cc=roid@nvidia.com \
--cc=vladbu@nvidia.com \
--cc=yang.guang5@zte.com.cn \
--cc=zealci@zte.com.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®