mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Nico Pache <npache@redhat.com>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-mm@kvack.org, David Hildenbrand <david@kernel.org>,
	Lorenzo Stoakes <ljs@kernel.org>, Zi Yan <ziy@nvidia.com>,
	Baolin Wang <baolin.wang@linux.alibaba.com>,
	"Liam R. Howlett" <liam@infradead.org>,
	Ryan Roberts <ryan.roberts@arm.com>, Dev Jain <dev.jain@arm.com>,
	Barry Song <baohua@kernel.org>, Lance Yang <lance.yang@linux.dev>,
	Usama Arif <usama.arif@linux.dev>,
	Vlastimil Babka <vbabka@kernel.org>,
	Mike Rapoport <rppt@kernel.org>,
	Suren Baghdasaryan <surenb@google.com>,
	Michal Hocko <mhocko@suse.com>, Jonathan Corbet <corbet@lwn.net>,
	Shuah Khan <skhan@linuxfoundation.org>
Subject: Re: [PATCH v2 0/7] mm/khugepaged: several cleanups
Date: Tue, 14 Jul 2026 23:59:17 -0600	[thread overview]
Message-ID: <b2661d8a-13cc-42d4-a850-a6f70a25e090@redhat.com> (raw)
In-Reply-To: <20260714214121.090238f5f0f318f8d82cbaa2@linux-foundation.org>



On Tue, Jul 14, 2026 at 10:41 PM Andrew Morton <akpm@linux-foundation.org> wrote:
>
> On Tue, 14 Jul 2026 20:59:29 -0600 Nico Pache <npache@redhat.com> wrote:
>
> > The following changes stem from a number of reviews during my khugepaged
> > mTHP support series [1]. Some of these are minor code cleanups, issues or
> > reviews that we decided to deferred to a followup series, or in the case
> > of the more major patch of the series, changes [2] Lance Yang attempted
> > while my series was in-flight and we decided to wait till later to try.
> >
> > The first 3 patches introduce helper functions to increase code reuse and
> > readability. This includes a per-scan state clearing function, extracting
> > the young page check into a helper, and a count_collapse_event() function
> > to reduce a repetative pattern used across mTHP collapse.
> >
> > The 4th patch was the byproduct of me throwing Claude at all the
> > comments in khugepaged verifying and looking for any outdated info.
> >
> > The 5th patch is based on Lance Yang's commit series [2] trying to extract
> > the PTE state checking into a helper function. This required a bit of
> > rewriting due to differences after mTHP collapse was introduced. I also
> > took into account the changes requested during his patches review cycle.
> >
> > The remaining 2 patches were review points during my mTHP series that we
> > agreed can be deferred to a later series.
> >
> > Thank you to those whos reviews and work I leveraged to achieve these
> > cleanups.
>
> Sashiko seems to have a good point about [5/7]:
>         https://sashiko.dev/#/patchset/20260715025941.1571316-1-npache@redhat.com

Ah whoops! When i sent the fixup for V1 I only did it in one location when it
should have been for both callers of collapse_check_pte(). Sorry about that.

Here is the fixup for the missing variable assignment

Thank you,
-- Nico

commit 52adeb9998fe84c1f997a3b3b6e98c93f9754c95
Author: Nico Pache <npache@redhat.com>
Date:   Tue Jul 14 23:50:54 2026 -0600

    fixup: always set the local folio after collapse_check_pte()
    
    If we dont set the local folio to the result from collapse_check_pte()
    we can end up with cases that the goto out will result in pointing to a
    stale folio from the last successful PTE check.
    
    Signed-off-by: Nico Pache <npache@redhat.com>

diff --git a/mm/khugepaged.c b/mm/khugepaged.c
index 40125dcb4de9..e5e349d0662e 100644
--- a/mm/khugepaged.c
+++ b/mm/khugepaged.c
@@ -1747,13 +1747,13 @@ static enum scan_result collapse_scan_pmd(struct mm_struct *mm,
 		cc->progress++;
 
 		pte_check = collapse_check_pte(pteval, addr, &ctx);
+		folio = ctx.folio;
 		if (pte_check == PTE_CHECK_FAIL) {
 			result = ctx.result;
 			goto out_unmap;
 		}
 		if (pte_check == PTE_CHECK_CONTINUE)
 			continue;
-		folio = ctx.folio;
 
 		/* Set bit for occupied pages */
 		__set_bit(i, cc->mthp_present_ptes);


>


      reply	other threads:[~2026-07-15  5:57 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-15  2:59 Nico Pache
2026-07-15  2:59 ` [PATCH v2 1/7] mm/khugepaged: refactor per-scan state clearing into collapse_control_init_scan() Nico Pache
2026-07-29  9:39   ` David Hildenbrand (Arm)
2026-07-30 14:44   ` Lorenzo Stoakes (ARM)
2026-07-15  2:59 ` [PATCH v2 2/7] mm/khugepaged: extract young page check into collapse_is_referenced() helper Nico Pache
2026-07-29  9:41   ` David Hildenbrand (Arm)
2026-07-29  9:41     ` David Hildenbrand (Arm)
2026-07-29  9:47   ` David Hildenbrand (Arm)
2026-07-30  7:52     ` Wei Yang
2026-07-30 12:15       ` David Hildenbrand (Arm)
2026-08-03 19:12         ` Nico Pache
2026-07-15  2:59 ` [PATCH v2 3/7] mm/khugepaged: introduce a count_collapse_event() helper Nico Pache
2026-07-29  9:43   ` David Hildenbrand (Arm)
2026-08-03 19:13     ` Nico Pache
2026-07-15  2:59 ` [PATCH v2 4/7] mm/khugepaged: fix outdated comments Nico Pache
2026-07-29  9:44   ` David Hildenbrand (Arm)
2026-08-03 19:14     ` Nico Pache
2026-07-15  2:59 ` [PATCH v2 5/7] mm/khugepaged: Refactor the PTE state checks into a helper Nico Pache
2026-07-15  2:59 ` [PATCH v2 6/7] mm/khugepaged: unmap pte before releasing vma write lock Nico Pache
2026-07-29  9:48   ` David Hildenbrand (Arm)
2026-07-15  2:59 ` [PATCH v2 7/7] mm: Documentation: clarify where the mTHP stats live Nico Pache
2026-07-29  9:48   ` David Hildenbrand (Arm)
2026-07-15  4:41 ` [PATCH v2 0/7] mm/khugepaged: several cleanups Andrew Morton
2026-07-15  5:59   ` Nico Pache [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b2661d8a-13cc-42d4-a850-a6f70a25e090@redhat.com \
    --to=npache@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=baohua@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=corbet@lwn.net \
    --cc=david@kernel.org \
    --cc=dev.jain@arm.com \
    --cc=lance.yang@linux.dev \
    --cc=liam@infradead.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=rppt@kernel.org \
    --cc=ryan.roberts@arm.com \
    --cc=skhan@linuxfoundation.org \
    --cc=surenb@google.com \
    --cc=usama.arif@linux.dev \
    --cc=vbabka@kernel.org \
    --cc=ziy@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®