mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Moger, Babu" <Babu.Moger@amd.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
	"tglx@linutronix.de" <tglx@linutronix.de>,
	"mingo@redhat.com" <mingo@redhat.com>,
	"hpa@zytor.com" <hpa@zytor.com>,
	"fenghua.yu@intel.com" <fenghua.yu@intel.com>,
	"james.morse@arm.com" <james.morse@arm.com>,
	"vikas.shivappa@linux.intel.com" <vikas.shivappa@linux.intel.com>,
	"tony.luck@intel.com" <tony.luck@intel.com>
Cc: "x86@kernel.org" <x86@kernel.org>,
	"peterz@infradead.org" <peterz@infradead.org>,
	"pombredanne@nexb.com" <pombredanne@nexb.com>,
	"gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>,
	"kstewart@linuxfoundation.org" <kstewart@linuxfoundation.org>,
	"bp@suse.de" <bp@suse.de>,
	"rafael.j.wysocki@intel.com" <rafael.j.wysocki@intel.com>,
	"ak@linux.intel.com" <ak@linux.intel.com>,
	"kirill.shutemov@linux.intel.com"
	<kirill.shutemov@linux.intel.com>,
	"xiaochen.shen@intel.com" <xiaochen.shen@intel.com>,
	"colin.king@canonical.com" <colin.king@canonical.com>,
	"Hurwitz, Sherry" <sherry.hurwitz@amd.com>,
	"Lendacky, Thomas" <Thomas.Lendacky@amd.com>,
	"pbonzini@redhat.com" <pbonzini@redhat.com>,
	"dwmw@amazon.co.uk" <dwmw@amazon.co.uk>,
	"luto@kernel.org" <luto@kernel.org>,
	"jroedel@suse.de" <jroedel@suse.de>,
	"jannh@google.com" <jannh@google.com>,
	"dima@arista.com" <dima@arista.com>,
	"jpoimboe@redhat.com" <jpoimboe@redhat.com>,
	"vkuznets@redhat.com" <vkuznets@redhat.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 01/11] arch/x86: Start renaming the rdt files to more generic names
Date: Wed, 10 Oct 2018 14:11:13 +0000	[thread overview]
Message-ID: <b2e7630a-db5c-9f69-5d7e-cac3e2bb4014@amd.com> (raw)
In-Reply-To: <ab692687-6398-cf9a-a027-b9ff4b3ffd5f@intel.com>

Hi Reinette,

On 10/09/2018 05:01 PM, Reinette Chatre wrote:
> Hi Babu,
> 
> On 10/9/2018 2:17 PM, Moger, Babu wrote:
>> On 10/09/2018 11:39 AM, Reinette Chatre wrote:
>>> Hi Babu,
>>>
>>> On 10/5/2018 1:55 PM, Moger, Babu wrote:
>>>> New generation of AMD processors start support RDT(or QOS) features.
>>>> With more than one vendors supporting these features, it seems more
>>>> appropriate to rename these files.
>>>>
>>>> Signed-off-by: Babu Moger <babu.moger@amd.com>
>>>> ---
>>>>  arch/x86/include/asm/{intel_rdt_sched.h => rdt_sched.h}     | 0
>>>>  arch/x86/kernel/cpu/Makefile                                | 6 +++---
>>>>  arch/x86/kernel/cpu/{intel_rdt.c => rdt.c}                  | 4 ++--
>>>>  arch/x86/kernel/cpu/{intel_rdt.h => rdt.h}                  | 0
>>>>  .../cpu/{intel_rdt_ctrlmondata.c => rdt_ctrlmondata.c}      | 2 +-
>>>>  arch/x86/kernel/cpu/{intel_rdt_monitor.c => rdt_monitor.c}  | 2 +-
>>>>  .../cpu/{intel_rdt_pseudo_lock.c => rdt_pseudo_lock.c}      | 6 +++---
>>>>  ...ntel_rdt_pseudo_lock_event.h => rdt_pseudo_lock_event.h} | 2 +-
>>>>  .../x86/kernel/cpu/{intel_rdt_rdtgroup.c => rdt_rdtgroup.c} | 4 ++--
>>>>  arch/x86/kernel/process_32.c                                | 2 +-
>>>>  arch/x86/kernel/process_64.c                                | 2 +-
>>>>  11 files changed, 15 insertions(+), 15 deletions(-)
>>>>  rename arch/x86/include/asm/{intel_rdt_sched.h => rdt_sched.h} (100%)
>>>>  rename arch/x86/kernel/cpu/{intel_rdt.c => rdt.c} (99%)
>>>>  rename arch/x86/kernel/cpu/{intel_rdt.h => rdt.h} (100%)
>>>>  rename arch/x86/kernel/cpu/{intel_rdt_ctrlmondata.c => rdt_ctrlmondata.c} (99%)
>>>>  rename arch/x86/kernel/cpu/{intel_rdt_monitor.c => rdt_monitor.c} (99%)
>>>>  rename arch/x86/kernel/cpu/{intel_rdt_pseudo_lock.c => rdt_pseudo_lock.c} (99%)
>>>>  rename arch/x86/kernel/cpu/{intel_rdt_pseudo_lock_event.h => rdt_pseudo_lock_event.h} (95%)
>>>>  rename arch/x86/kernel/cpu/{intel_rdt_rdtgroup.c => rdt_rdtgroup.c} (99%)
>>>
>>> During the RFC it was agreed that "resctrl" will be the neutral name and
>>> "intel_rdt", "amd_qos", or "arm mpam" would be the vendor specific names.
>>>
>>> It is ok to delay that renaming but I think any renaming done from this
>>> point should respect this agreement.
>>>
>>> For example, if you want to rename intel_rdt.c then please rename it to
>>> resctrl.c instead of just rdt.c which does not represent a generic name
>>> as expressed as a goal in the subject of this patch.
>>
>> I knew this was going to bit tricky. I can change all the places where I
>> am touching the code to generic names(change from intel_rdt to "resctrl").
> 
> Yes, "intel_rdt" can be changed to the generic "resctrl" when it is not
> vendor specific.

Ok. sure.

> 
> As far as all the code you touch is concerned it may be easier and cause
> less confusion for now to just follow the current naming conventions as
> you have done in patches 3 onwards and have it be included in the later
> larger restructuring.

Yes. I am making sure first 3 patches are renamed to "resctrl" wherever
applicable. Will send the patches soon.

But I am confused about what you meant by "have it be included in the
later larger restructuring". Can you please elaborate?

> 
>> Also lets change the "texts" which are visible to user to make it more
>> generic.
> 
> Could you please elaborate what you mean with "texts" here? Are you
> referring to the pr_info() found in intel_rdt_late_init()? Here it may
> be good to also change to print "RESCTRL %s allocation
> detected"/"RESCTRL %s monitoring detected" - the resource names printed
> are already generic.

Yes. I meant pr_info text.  Will change it to print "RESCTRL"

> 
>> But "rdt" has been used generously in multiple files(like rdt_resource,
>> rdt_domain etc). Changing those definitions and functions will be messier.
>> I will not worry about it now. Thoughts?
> 
> I agree. My comments were specific to the first two patches of this
> series that started doing the renaming but not using the agreed upon
> naming - especially since both those patches claim to transition to
> generic names. Could just these two patches be modified to change
> "intel_rdt" to "resctrl" instead of "intel_rdt" to "rdt" as it currently
> does?

Sure.  Will take care of that.

> 
> Reinette
> 
> 

  reply	other threads:[~2018-10-10 14:11 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-05 20:55 [PATCH v2 00/11] arch/x86: AMD QoS support Moger, Babu
2018-10-05 20:55 ` [PATCH v2 01/11] arch/x86: Start renaming the rdt files to more generic names Moger, Babu
2018-10-09 16:39   ` Reinette Chatre
2018-10-09 21:17     ` Moger, Babu
2018-10-09 22:01       ` Reinette Chatre
2018-10-10 14:11         ` Moger, Babu [this message]
2018-10-10 14:16           ` Thomas Gleixner
2018-10-10 14:30             ` Moger, Babu
2018-10-10 17:53           ` Reinette Chatre
2018-10-10 18:06             ` Moger, Babu
2018-10-05 20:55 ` [PATCH v2 02/11] arch/x86: Rename the RDT functions and definitions Moger, Babu
2018-10-09 16:42   ` Reinette Chatre
2018-10-05 20:55 ` [PATCH v2 03/11] arch/x86: Re-arrange RDT init code Moger, Babu
2018-10-05 20:55 ` [PATCH v2 04/11] arch/x86: Bring all the macros to rdt.h Moger, Babu
2018-10-05 20:55 ` [PATCH v2 05/11] arch/x86: Introduce a new config parameter PLATFORM_QOS Moger, Babu
2018-10-05 23:38   ` Fenghua Yu
2018-10-08  1:22     ` Moger, Babu
2018-10-05 20:55 ` [PATCH v2 06/11] arch/x86: Use new config parameter PLATFORM_QOS for compilation Moger, Babu
2018-10-05 20:55 ` [PATCH v2 07/11] arch/x86: Initialize the resource functions that are different Moger, Babu
2018-10-09 17:18   ` Reinette Chatre
2018-10-09 20:45     ` Moger, Babu
2018-10-05 20:56 ` [PATCH v2 08/11] arch/x86: Bring few more functions into the resource structure Moger, Babu
2018-10-05 20:56 ` [PATCH v2 09/11] arch/x86: Introduce new config parameter AMD_QOS Moger, Babu
2018-10-05 20:56 ` [PATCH v2 10/11] arch/x86: Add AMD feature bit X86_FEATURE_MBA in cpuid bits array Moger, Babu
2018-10-05 21:31   ` Borislav Petkov
2018-10-08  1:25     ` Moger, Babu
2018-10-05 20:56 ` [PATCH v2 11/11] arch/x86: Introduce QOS feature for AMD Moger, Babu
2018-11-02  6:43 ` [PATCH v2 00/11] arch/x86: AMD QoS support Jon Masters
2018-11-02 14:07   ` Moger, Babu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b2e7630a-db5c-9f69-5d7e-cac3e2bb4014@amd.com \
    --to=babu.moger@amd.com \
    --cc=Thomas.Lendacky@amd.com \
    --cc=ak@linux.intel.com \
    --cc=bp@suse.de \
    --cc=colin.king@canonical.com \
    --cc=dima@arista.com \
    --cc=dwmw@amazon.co.uk \
    --cc=fenghua.yu@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hpa@zytor.com \
    --cc=james.morse@arm.com \
    --cc=jannh@google.com \
    --cc=jpoimboe@redhat.com \
    --cc=jroedel@suse.de \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=kstewart@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@kernel.org \
    --cc=mingo@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=peterz@infradead.org \
    --cc=pombredanne@nexb.com \
    --cc=rafael.j.wysocki@intel.com \
    --cc=reinette.chatre@intel.com \
    --cc=sherry.hurwitz@amd.com \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=vikas.shivappa@linux.intel.com \
    --cc=vkuznets@redhat.com \
    --cc=x86@kernel.org \
    --cc=xiaochen.shen@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome