From: Logan Gunthorpe <logang@deltatee.com>
To: Matt Evans <matt@ozlabs.org>, Leon Romanovsky <leon@kernel.org>,
Jason Gunthorpe <jgg@nvidia.com>
Cc: "Alex Williamson" <alex@shazbot.org>,
"Alex Mastro" <amastro@fb.com>,
"Bjorn Helgaas" <bhelgaas@google.com>,
"Kevin Tian" <kevin.tian@intel.com>,
"Pranjal Shrivastava" <praan@google.com>,
"Mahmoud Adam" <mngyadam@amazon.de>,
"David Matlack" <dmatlack@google.com>,
"Björn Töpel" <bjorn@kernel.org>,
"Sumit Semwal" <sumit.semwal@linaro.org>,
"Ankit Agrawal" <ankita@nvidia.com>,
"Christian König" <christian.koenig@amd.com>,
"Alistair Popple" <apopple@nvidia.com>,
"Vivek Kasireddy" <vivek.kasireddy@intel.com>,
linux-kernel@vger.kernel.org, linux-media@vger.kernel.org,
dri-devel@lists.freedesktop.org, linaro-mm-sig@lists.linaro.org,
kvm@vger.kernel.org, linux-pci@vger.kernel.org,
"Longfang Liu" <liulongfang@huawei.com>
Subject: Re: [PATCH v5 2/9] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CORE
Date: Tue, 4 Aug 2026 10:19:11 -0600 [thread overview]
Message-ID: <b30e75d8-37d6-478d-bc72-a9ed0b7e200c@deltatee.com> (raw)
In-Reply-To: <e90b0bd0-fb8e-4d4e-b282-609c26692e4a@ozlabs.org>
On 2026-08-04 09:42, Matt Evans wrote:
>
> Just shoving an #ifdef in mlx5 isn't right, so would be grateful for
> your advice on the most tasteful resolution:
>
> 1. Imagining future drivers might use pcim_p2pdma_provider(), maybe
> p2pdma could export a `pcim_p2pdma_supported()` or similar which
> returns whether CONFIG_PCI_P2PDMA is present and P2P can ever work.
> A user of pcim_p2pdma_provider() is required to also check if P2P is
> overall supported.
>
> Ugliness aside, a driver could use #ifdef CONFIG_PCI_P2PDMA to test
> whether P2P is expected to work, except that doesn't stop modules
> falling into the same trap. I think a function export is better.
>
> 2. And/or a test (such the function from #1, or an #ifdef) in the IB
> core DMABUF path, to avoid individual drivers from doing the test in
> their .mmap_get_pfns(). Other future drivers would be expected to
> do similar.
>
> Any better ideas? Sorry I didn't catch this earlier in the review
> cycles, I know we've looked at this patch a few times now.
I see the problem now. Yes, it's a bit tricky and I don't have a great
answer. But the proposed solution seems very confusing. I definitely
don't think we should be adding ifdefs in the IB core for this.
For me, this is mainly a naming problem as there's a bunch of ways to
address it in the code. The question is what do we call p2pdma vs. core
p2pdma in a way that makes the distinction more obvious.
There's a vague convention for this already: the term 'p2pmem' is often
used for cases where the driver uses the allocator, etc. (I think I had
this intention when I wrote the code and have since forgotten about it).
I'm thinking we should lean into that more and instead of introducing
CONFIG_PCI_P2PDMA_CORE we introduce CONFIG_PCI_P2PMEM and move all that
code into it's own file, potentially renaming some functions. Then, in
the end, we would probably have a pcim_p2pdma_supported() function and a
pcim_p2pmem_supported() function, the latter being used by existing use
cases.
Logan
next prev parent reply other threads:[~2026-08-04 16:55 UTC|newest]
Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-15 17:47 [PATCH v5 0/9] vfio/pci: Add mmap() for DMABUFs Matt Evans
2026-07-15 17:47 ` [PATCH v5 1/9] PCI/P2PDMA: Split pool-related cleanup out of pci_p2pdma_release() Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-28 22:33 ` Alex Williamson
2026-07-29 10:08 ` Leon Romanovsky
2026-08-05 0:31 ` Jason Gunthorpe
2026-07-30 16:45 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 2/9] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CORE Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-30 19:37 ` Pranjal Shrivastava
2026-08-04 15:42 ` Matt Evans
2026-08-04 16:19 ` Logan Gunthorpe [this message]
2026-08-05 0:39 ` Jason Gunthorpe
2026-08-05 16:28 ` Matt Evans
2026-08-05 16:40 ` Jason Gunthorpe
2026-08-05 20:50 ` Logan Gunthorpe
2026-08-11 13:45 ` Matt Evans
2026-08-11 14:01 ` Jason Gunthorpe
2026-07-15 17:47 ` [PATCH v5 3/9] vfio/pci: Add a helper to look up PFNs for DMABUFs Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 17:34 ` Matt Evans
2026-07-30 22:55 ` Pranjal Shrivastava
2026-07-31 17:43 ` Matt Evans
2026-08-03 18:22 ` Matt Evans
2026-08-04 19:01 ` Pranjal Shrivastava
2026-08-05 0:41 ` Jason Gunthorpe
2026-07-15 17:47 ` [PATCH v5 4/9] vfio/pci: Add a helper to create a DMABUF for a BAR-map VMA Matt Evans
2026-08-12 22:39 ` Matt Evans
2026-08-13 22:48 ` Alex Williamson
2026-07-15 17:47 ` [PATCH v5 5/9] vfio/pci: Convert BAR mmap() to use a DMABUF Matt Evans
2026-07-15 17:47 ` [PATCH v5 6/9] vfio/pci: Provide a user-facing name for BAR mappings Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 14:37 ` Matt Evans
2026-07-15 17:47 ` [PATCH v5 7/9] vfio/pci: Clean up BAR zap and revocation Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 14:47 ` Matt Evans
2026-08-04 20:10 ` Alex Williamson
2026-08-05 13:58 ` Matt Evans
2026-08-11 15:58 ` Matt Evans
2026-08-12 20:06 ` Alex Williamson
2026-08-13 15:49 ` Matt Evans
2026-07-30 23:20 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 8/9] vfio/pci: Support mmap() of a VFIO DMABUF Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-30 23:33 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 9/9] vfio/pci: Permanently revoke a DMABUF on request Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-30 23:43 ` Pranjal Shrivastava
2026-07-15 18:12 ` [PATCH v5 0/9] vfio/pci: Add mmap() for DMABUFs David Matlack
2026-07-16 14:51 ` Matt Evans
2026-07-16 21:23 ` David Matlack
2026-07-17 8:42 ` David Laight
2026-07-17 16:30 ` David Matlack
2026-07-17 17:12 ` Matt Evans
2026-07-20 21:50 ` David Matlack
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b30e75d8-37d6-478d-bc72-a9ed0b7e200c@deltatee.com \
--to=logang@deltatee.com \
--cc=alex@shazbot.org \
--cc=amastro@fb.com \
--cc=ankita@nvidia.com \
--cc=apopple@nvidia.com \
--cc=bhelgaas@google.com \
--cc=bjorn@kernel.org \
--cc=christian.koenig@amd.com \
--cc=dmatlack@google.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=jgg@nvidia.com \
--cc=kevin.tian@intel.com \
--cc=kvm@vger.kernel.org \
--cc=leon@kernel.org \
--cc=linaro-mm-sig@lists.linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=liulongfang@huawei.com \
--cc=matt@ozlabs.org \
--cc=mngyadam@amazon.de \
--cc=praan@google.com \
--cc=sumit.semwal@linaro.org \
--cc=vivek.kasireddy@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®