mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Gao Xiang <hsiangkao@linux.alibaba.com>
To: Jingbo Xu <jefflexu@linux.alibaba.com>,
	xiang@kernel.org, chao@kernel.org, huyue2@coolpad.com,
	linux-erofs@lists.ozlabs.org
Cc: linux-kernel@vger.kernel.org
Subject: Re: [PATCH v8 5/5] erofs: use separate xattr parsers for listxattr/getxattr
Date: Tue, 13 Jun 2023 21:25:30 +0800	[thread overview]
Message-ID: <b33fbbdf-42b2-b260-39a6-77f6356851f8@linux.alibaba.com> (raw)
In-Reply-To: <20230613074114.120115-6-jefflexu@linux.alibaba.com>



On 2023/6/13 15:41, Jingbo Xu wrote:
> There's a callback styled xattr parser, i.e. xattr_foreach(), which is
> shared among listxattr and getxattr.
> 
> Convert it to two separate xattr parsers to serve listxattr and getxattr
> for better readability.
> 
> Signed-off-by: Jingbo Xu <jefflexu@linux.alibaba.com>

Reviewed-by: Gao Xiang <hsiangkao@linux.alibaba.com>

Thanks,
Gao Xiang

      reply	other threads:[~2023-06-13 13:25 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-06-13  7:41 [PATCH v8 0/5] erofs: cleanup of xattr handling Jingbo Xu
2023-06-13  7:41 ` [PATCH v8 1/5] erofs: use absolute position in xattr iterator Jingbo Xu
2023-06-13  7:41 ` [PATCH v8 2/5] erofs: unify xattr_iter structures Jingbo Xu
2023-06-13  7:41 ` [PATCH v8 3/5] erofs: make the size of read data stored in buffer_ofs Jingbo Xu
2023-06-13  7:41 ` [PATCH v8 4/5] erofs: unify inline/shared xattr iterators for listxattr/getxattr Jingbo Xu
2023-06-13 13:25   ` Gao Xiang
2023-06-13  7:41 ` [PATCH v8 5/5] erofs: use separate xattr parsers " Jingbo Xu
2023-06-13 13:25   ` Gao Xiang [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b33fbbdf-42b2-b260-39a6-77f6356851f8@linux.alibaba.com \
    --to=hsiangkao@linux.alibaba.com \
    --cc=chao@kernel.org \
    --cc=huyue2@coolpad.com \
    --cc=jefflexu@linux.alibaba.com \
    --cc=linux-erofs@lists.ozlabs.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=xiang@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®