From: Kirti Wankhede <kwankhede@nvidia.com>
To: <alex.williamson@redhat.com>, <pbonzini@redhat.com>,
<kraxel@redhat.com>, <cjia@nvidia.com>, <qemu-devel@nongnu.org>,
<kvm@vger.kernel.org>, <kevin.tian@intel.com>,
<jike.song@intel.com>, <bjsdjshi@linux.vnet.ibm.com>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v13 09/22] vfio iommu type1: Add task structure to vfio_dma
Date: Wed, 16 Nov 2016 20:41:57 +0530 [thread overview]
Message-ID: <b3cdb748-ea5b-d00f-fbb5-b1609ab424a5@nvidia.com> (raw)
In-Reply-To: <20161116060628.GC5531@bjsdjshi@linux.vnet.ibm.com>
On 11/16/2016 11:36 AM, Dong Jia Shi wrote:
> * Kirti Wankhede <kwankhede@nvidia.com> [2016-11-15 20:59:52 +0530]:
>
> Hi Kirti,
>
> [...]
> diff --git a/drivers/vfio/vfio_iommu_type1.c b/drivers/vfio/vfio_iommu_type1.c
>
>> @@ -331,13 +338,16 @@ static long vfio_pin_pages_remote(unsigned long vaddr, long npage,
>> }
>>
>> if (!rsvd)
>> - vfio_lock_acct(current, i);
>> + vfio_lock_acct(dma->task, i);
>> + ret = i;
>>
>> - return i;
>> +pin_pg_remote_exit:
> out_mmput sounds a better name to me.
>
>> + mmput(mm);
>> + return ret;
>> }
>>
> [...]
>
>> @@ -510,6 +521,12 @@ static int vfio_dma_do_unmap(struct vfio_iommu *iommu,
>> while ((dma = vfio_find_dma(iommu, unmap->iova, unmap->size))) {
>> if (!iommu->v2 && unmap->iova > dma->iova)
>> break;
>> + /*
>> + * Task with same address space who mapped this iova range is
>> + * allowed to unmap the iova range.
>> + */
>> + if (dma->task->mm != current->mm)
> How about:
> if (dma->task != current)
>
As I mentioned in comment above this and commit description, if a
process calls DMA_MAP, forks a thread and then child thread calls
DMA_UNMAP, this should be allowed since address space is same for parent
process and child. QEMU also works that way.
>> + break;
>> unmapped += dma->size;
>> vfio_remove_dma(iommu, dma);
>> }
>> @@ -576,17 +593,55 @@ unwind:
>> return ret;
>> }
>>
>> +static int vfio_pin_map_dma(struct vfio_iommu *iommu, struct vfio_dma *dma,
>> + size_t map_size)
> Do you factor out this function for future usage?
> I didn't find the other callers.
>
This is pulled out to make caller simple and short. Otherwise
vfio_dma_do_map() would have become a long function.
>> +{
>> + dma_addr_t iova = dma->iova;
>> + unsigned long vaddr = dma->vaddr;
>> + size_t size = map_size;
>> + long npage;
>> + unsigned long pfn;
>> + int ret = 0;
>> +
>> + while (size) {
>> + /* Pin a contiguous chunk of memory */
>> + npage = vfio_pin_pages_remote(dma, vaddr + dma->size,
>> + size >> PAGE_SHIFT, dma->prot,
>> + &pfn);
>> + if (npage <= 0) {
>> + WARN_ON(!npage);
>> + ret = (int)npage;
>> + break;
>> + }
>> +
>> + /* Map it! */
>> + ret = vfio_iommu_map(iommu, iova + dma->size, pfn, npage,
>> + dma->prot);
>> + if (ret) {
>> + vfio_unpin_pages_remote(dma, pfn, npage,
>> + dma->prot, true);
>> + break;
>> + }
>> +
>> + size -= npage << PAGE_SHIFT;
>> + dma->size += npage << PAGE_SHIFT;
>> + }
>> +
>> + if (ret)
>> + vfio_remove_dma(iommu, dma);
>> +
>> + return ret;
>> +}
>> +
>> static int vfio_dma_do_map(struct vfio_iommu *iommu,
>> struct vfio_iommu_type1_dma_map *map)
>> {
>> dma_addr_t iova = map->iova;
>> unsigned long vaddr = map->vaddr;
>> size_t size = map->size;
>> - long npage;
>> int ret = 0, prot = 0;
>> uint64_t mask;
>> struct vfio_dma *dma;
>> - unsigned long pfn;
>>
>> /* Verify that none of our __u64 fields overflow */
>> if (map->size != size || map->vaddr != vaddr || map->iova != iova)
>> @@ -612,47 +667,27 @@ static int vfio_dma_do_map(struct vfio_iommu *iommu,
>> mutex_lock(&iommu->lock);
>>
>> if (vfio_find_dma(iommu, iova, size)) {
>> - mutex_unlock(&iommu->lock);
>> - return -EEXIST;
>> + ret = -EEXIST;
>> + goto do_map_err;
>> }
>>
>> dma = kzalloc(sizeof(*dma), GFP_KERNEL);
>> if (!dma) {
>> - mutex_unlock(&iommu->lock);
>> - return -ENOMEM;
>> + ret = -ENOMEM;
>> + goto do_map_err;
>> }
>>
>> dma->iova = iova;
>> dma->vaddr = vaddr;
>> dma->prot = prot;
>> + get_task_struct(current);
>> + dma->task = current;
>>
>> /* Insert zero-sized and grow as we map chunks of it */
>> vfio_link_dma(iommu, dma);
>>
>> - while (size) {
>> - /* Pin a contiguous chunk of memory */
>> - npage = vfio_pin_pages_remote(vaddr + dma->size,
>> - size >> PAGE_SHIFT, prot, &pfn);
>> - if (npage <= 0) {
>> - WARN_ON(!npage);
>> - ret = (int)npage;
>> - break;
>> - }
>> -
>> - /* Map it! */
>> - ret = vfio_iommu_map(iommu, iova + dma->size, pfn, npage, prot);
>> - if (ret) {
>> - vfio_unpin_pages_remote(pfn, npage, prot, true);
>> - break;
>> - }
>> -
>> - size -= npage << PAGE_SHIFT;
>> - dma->size += npage << PAGE_SHIFT;
>> - }
>> -
>> - if (ret)
>> - vfio_remove_dma(iommu, dma);
>> -
>> + ret = vfio_pin_map_dma(iommu, dma, size);
>> +do_map_err:
> Rename to out_unlock?
>
>> mutex_unlock(&iommu->lock);
>> return ret;
>> }
>> --
>> 2.7.0
>>
>
> Otherwise, LGTM!
>
Thanks.
Kirti.
next prev parent reply other threads:[~2016-11-16 15:12 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-11-15 15:29 [PATCH v13 00/22] Add Mediated device support Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 01/22] vfio: Mediated device Core driver Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 02/22] vfio: VFIO based driver for Mediated devices Kirti Wankhede
[not found] ` <20161116022958.GA5531@bjsdjshi@linux.vnet.ibm.com>
2016-11-16 15:05 ` Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 03/22] vfio: Rearrange functions to get vfio_group from dev Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 04/22] vfio: Common function to increment container_users Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 05/22] vfio iommu: Added pin and unpin callback functions to vfio_iommu_driver_ops Kirti Wankhede
[not found] ` <20161116030328.GB5531@bjsdjshi@linux.vnet.ibm.com>
2016-11-16 15:06 ` Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 06/22] vfio iommu type1: Update arguments of vfio_lock_acct Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 07/22] vfio iommu type1: Update argument of vaddr_get_pfn() Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 08/22] vfio iommu type1: Add find_iommu_group() function Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 09/22] vfio iommu type1: Add task structure to vfio_dma Kirti Wankhede
[not found] ` <20161116060628.GC5531@bjsdjshi@linux.vnet.ibm.com>
2016-11-16 15:11 ` Kirti Wankhede [this message]
2016-11-15 15:29 ` [PATCH v13 10/22] vfio iommu type1: Add support for mediated devices Kirti Wankhede
2016-11-15 20:54 ` Alex Williamson
2016-11-15 15:29 ` [PATCH v13 11/22] vfio iommu: Add blocking notifier to notify DMA_UNMAP Kirti Wankhede
2016-11-15 22:19 ` Alex Williamson
2016-11-16 2:46 ` Kirti Wankhede
2016-11-16 3:16 ` Alex Williamson
2016-11-16 3:25 ` Alex Williamson
2016-11-16 3:43 ` Kirti Wankhede
2016-11-16 3:58 ` Alex Williamson
2016-11-16 4:16 ` Kirti Wankhede
2016-11-16 4:36 ` Alex Williamson
2016-11-16 15:22 ` Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 12/22] vfio: Add notifier callback to parent's ops structure of mdev Kirti Wankhede
[not found] ` <20161116063759.GD5531@bjsdjshi@linux.vnet.ibm.com>
2016-11-16 15:17 ` Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 13/22] vfio: Introduce common function to add capabilities Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 14/22] vfio_pci: Update vfio_pci to use vfio_info_add_capability() Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 15/22] vfio: Introduce vfio_set_irqs_validate_and_prepare() Kirti Wankhede
2016-11-15 15:29 ` [PATCH v13 16/22] vfio_pci: Updated to use vfio_set_irqs_validate_and_prepare() Kirti Wankhede
2016-11-15 15:30 ` [PATCH v13 17/22] vfio_platform: " Kirti Wankhede
2016-11-15 15:30 ` [PATCH v13 18/22] vfio: Define device_api strings Kirti Wankhede
2016-11-15 15:30 ` [PATCH v13 19/22] docs: Add Documentation for Mediated devices Kirti Wankhede
2016-11-15 15:30 ` [PATCH v13 20/22] docs: Sysfs ABI for mediated device framework Kirti Wankhede
2016-11-15 15:30 ` [PATCH v13 21/22] docs: Sample driver to demonstrate how to use Mediated " Kirti Wankhede
2016-11-15 15:30 ` [PATCH v13 22/22] MAINTAINERS: Add entry VFIO based Mediated device drivers Kirti Wankhede
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b3cdb748-ea5b-d00f-fbb5-b1609ab424a5@nvidia.com \
--to=kwankhede@nvidia.com \
--cc=alex.williamson@redhat.com \
--cc=bjsdjshi@linux.vnet.ibm.com \
--cc=cjia@nvidia.com \
--cc=jike.song@intel.com \
--cc=kevin.tian@intel.com \
--cc=kraxel@redhat.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=qemu-devel@nongnu.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®