From: "Stamatis, Ilias" <ilstam@amazon.com>
To: "seanjc@google.com" <seanjc@google.com>
Cc: "kvm@vger.kernel.org" <kvm@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"jmattson@google.com" <jmattson@google.com>,
"Woodhouse, David" <dwmw@amazon.co.uk>,
"vkuznets@redhat.com" <vkuznets@redhat.com>,
"joro@8bytes.org" <joro@8bytes.org>,
"mtosatti@redhat.com" <mtosatti@redhat.com>,
"zamsden@gmail.com" <zamsden@gmail.com>,
"pbonzini@redhat.com" <pbonzini@redhat.com>,
"mlevitsk@redhat.com" <mlevitsk@redhat.com>,
"wanpengli@tencent.com" <wanpengli@tencent.com>
Subject: Re: [PATCH v2 02/10] KVM: X86: Store L1's TSC scaling ratio in 'struct kvm_vcpu_arch'
Date: Wed, 19 May 2021 08:54:49 +0000 [thread overview]
Message-ID: <b3f785d4dccf7f8235103f85d814be34c51987e6.camel@amazon.com> (raw)
In-Reply-To: <YKRFSaktB4+tgFUH@google.com>
On Tue, 2021-05-18 at 22:52 +0000, Sean Christopherson wrote:
> On Wed, May 12, 2021, Ilias Stamatis wrote:
> > Store L1's scaling ratio in that struct like we already do for L1's TSC
>
> s/that struct/kvm_vcpu_arch. Forcing the reader to look at the subject to
> understand the changelog is annoying, especially when it saves all of a handful
> of characters. E.g. I often read patches without the subject in scope.
>
> > offset. This allows for easy save/restore when we enter and then exit
> > the nested guest.
> >
> > Signed-off-by: Ilias Stamatis <ilstam@amazon.com>
> > Reviewed-by: Maxim Levitsky <mlevitsk@redhat.com>
> > ---
>
> ...
>
> > diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c
> > index 9b6bca616929..07cf5d7ece38 100644
> > --- a/arch/x86/kvm/x86.c
> > +++ b/arch/x86/kvm/x86.c
> > @@ -2185,6 +2185,7 @@ static int set_tsc_khz(struct kvm_vcpu *vcpu, u32 user_tsc_khz, bool scale)
> >
> > /* Guest TSC same frequency as host TSC? */
> > if (!scale) {
> > + vcpu->arch.l1_tsc_scaling_ratio = kvm_default_tsc_scaling_ratio;
> > vcpu->arch.tsc_scaling_ratio = kvm_default_tsc_scaling_ratio;
>
> Looks like these are always set as a pair, maybe add a helper, e.g.
>
> static void kvm_set_l1_tsc_scaling_ratio(u64 ratio)
> {
> vcpu->arch.l1_tsc_scaling_ratio = ratio;
> vcpu->arch.tsc_scaling_ratio = ratio;
> }
>
Hmm, they are not *always* set as a pair. Plus wouldn't this name be a bit
misleading suggesting that L1's scaling ratio is updated but implicitly
changing the current ratio too?
I'm not sure a helper function would add much
value here.
> > return 0;
> > }
> > @@ -2211,7 +2212,7 @@ static int set_tsc_khz(struct kvm_vcpu *vcpu, u32 user_tsc_khz, bool scale)
> > return -1;
> > }
> >
> > - vcpu->arch.tsc_scaling_ratio = ratio;
> > + vcpu->arch.l1_tsc_scaling_ratio = vcpu->arch.tsc_scaling_ratio = ratio;
> > return 0;
> > }
> >
> > @@ -2223,6 +2224,7 @@ static int kvm_set_tsc_khz(struct kvm_vcpu *vcpu, u32 user_tsc_khz)
> > /* tsc_khz can be zero if TSC calibration fails */
> > if (user_tsc_khz == 0) {
> > /* set tsc_scaling_ratio to a safe value */
> > + vcpu->arch.l1_tsc_scaling_ratio = kvm_default_tsc_scaling_ratio;
> > vcpu->arch.tsc_scaling_ratio = kvm_default_tsc_scaling_ratio;
> > return -1;
> > }
> > @@ -2459,7 +2461,7 @@ static inline void adjust_tsc_offset_guest(struct kvm_vcpu *vcpu,
> >
> > static inline void adjust_tsc_offset_host(struct kvm_vcpu *vcpu, s64 adjustment)
> > {
> > - if (vcpu->arch.tsc_scaling_ratio != kvm_default_tsc_scaling_ratio)
> > + if (vcpu->arch.l1_tsc_scaling_ratio != kvm_default_tsc_scaling_ratio)
> > WARN_ON(adjustment < 0);
> > adjustment = kvm_scale_tsc(vcpu, (u64) adjustment);
> > adjust_tsc_offset_guest(vcpu, adjustment);
> > --
> > 2.17.1
> >
next prev parent reply other threads:[~2021-05-19 8:55 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-05-12 15:09 [PATCH v2 00/10] KVM: Implement nested TSC scaling Ilias Stamatis
2021-05-12 15:09 ` [PATCH v2 01/10] math64.h: Add mul_s64_u64_shr() Ilias Stamatis
2021-05-18 22:36 ` Sean Christopherson
2021-05-12 15:09 ` [PATCH v2 02/10] KVM: X86: Store L1's TSC scaling ratio in 'struct kvm_vcpu_arch' Ilias Stamatis
2021-05-18 22:52 ` Sean Christopherson
2021-05-19 8:54 ` Stamatis, Ilias [this message]
2021-05-12 15:09 ` [PATCH v2 03/10] KVM: X86: Add kvm_scale_tsc_l1() and kvm_compute_tsc_offset_l1() Ilias Stamatis
2021-05-18 23:04 ` Sean Christopherson
2021-05-19 9:02 ` Stamatis, Ilias
2021-05-19 15:40 ` Sean Christopherson
2021-05-20 18:27 ` Stamatis, Ilias
2021-05-12 15:09 ` [PATCH v2 04/10] KVM: VMX: Add a TSC multiplier field in VMCS12 Ilias Stamatis
2021-05-12 15:09 ` [PATCH v2 05/10] KVM: X86: Add functions for retrieving L2 TSC fields from common code Ilias Stamatis
2021-05-12 15:09 ` [PATCH v2 06/10] KVM: X86: Add functions that calculate the 02 TSC offset and multiplier Ilias Stamatis
2021-05-18 23:21 ` Sean Christopherson
2021-05-19 10:15 ` Stamatis, Ilias
2021-05-12 15:09 ` [PATCH v2 07/10] KVM: X86: Move write_l1_tsc_offset() logic to common code and rename it Ilias Stamatis
2021-05-19 0:05 ` Sean Christopherson
2021-05-19 11:45 ` Stamatis, Ilias
2021-05-19 15:49 ` Sean Christopherson
2021-05-12 15:09 ` [PATCH v2 08/10] KVM: VMX: Set the TSC offset and multiplier on nested entry and exit Ilias Stamatis
2021-05-19 0:07 ` Sean Christopherson
2021-05-19 11:55 ` Stamatis, Ilias
2021-05-12 15:09 ` [PATCH v2 09/10] KVM: VMX: Expose TSC scaling to L2 Ilias Stamatis
2021-05-12 15:09 ` [PATCH v2 10/10] KVM: selftests: x86: Add vmx_nested_tsc_scaling_test Ilias Stamatis
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b3f785d4dccf7f8235103f85d814be34c51987e6.camel@amazon.com \
--to=ilstam@amazon.com \
--cc=dwmw@amazon.co.uk \
--cc=jmattson@google.com \
--cc=joro@8bytes.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mlevitsk@redhat.com \
--cc=mtosatti@redhat.com \
--cc=pbonzini@redhat.com \
--cc=seanjc@google.com \
--cc=vkuznets@redhat.com \
--cc=wanpengli@tencent.com \
--cc=zamsden@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome