mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Yi Liu <yi.l.liu@intel.com>
To: Lu Baolu <baolu.lu@linux.intel.com>,
	Joerg Roedel <joro@8bytes.org>,
	"Kevin Tian" <kevin.tian@intel.com>,
	Jacob Pan <jacob.jun.pan@linux.intel.com>
Cc: Will Deacon <will@kernel.org>,
	Robin Murphy <robin.murphy@arm.com>, <iommu@lists.linux.dev>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/2] iommu/vt-d: Convert dmar_ats_supported() to return bool
Date: Mon, 24 Jun 2024 16:12:04 +0800	[thread overview]
Message-ID: <b5797453-3e19-469f-8a0b-71fe4c5add1a@intel.com> (raw)
In-Reply-To: <20240624052501.253405-1-baolu.lu@linux.intel.com>

On 2024/6/24 13:25, Lu Baolu wrote:
> dmar_ats_supported() returns an integer that is used as a boolean. Since
> it all it needs is to return true or false, change the return type from

nit: a redundant "it" is used here.

> int to bool to make it a bit more readable and obvious.
> 
> Cleanup this helper accordingly with no functional change intended.
> 
> Signed-off-by: Lu Baolu <baolu.lu@linux.intel.com>
> ---
>   drivers/iommu/intel/iommu.c | 33 ++++++++++++++++++---------------
>   1 file changed, 18 insertions(+), 15 deletions(-)
> 
> diff --git a/drivers/iommu/intel/iommu.c b/drivers/iommu/intel/iommu.c
> index 38cda454fc64..07e394dfccc1 100644
> --- a/drivers/iommu/intel/iommu.c
> +++ b/drivers/iommu/intel/iommu.c
> @@ -3043,15 +3043,15 @@ static struct dmar_satc_unit *dmar_find_matched_satc_unit(struct pci_dev *dev)
>   	return satcu;
>   }
>   
> -static int dmar_ats_supported(struct pci_dev *dev, struct intel_iommu *iommu)
> +static bool dmar_ats_supported(struct pci_dev *dev, struct intel_iommu *iommu)
>   {
> -	int i, ret = 1;
> -	struct pci_bus *bus;
>   	struct pci_dev *bridge = NULL;
> -	struct device *tmp;
> -	struct acpi_dmar_atsr *atsr;
>   	struct dmar_atsr_unit *atsru;
>   	struct dmar_satc_unit *satcu;
> +	struct acpi_dmar_atsr *atsr;
> +	struct pci_bus *bus;
> +	struct device *tmp;
> +	int i;
>   
>   	dev = pci_physfn(dev);
>   	satcu = dmar_find_matched_satc_unit(dev);
> @@ -3069,11 +3069,11 @@ static int dmar_ats_supported(struct pci_dev *dev, struct intel_iommu *iommu)
>   		bridge = bus->self;
>   		/* If it's an integrated device, allow ATS */
>   		if (!bridge)
> -			return 1;
> +			return true;
>   		/* Connected via non-PCIe: no ATS */
>   		if (!pci_is_pcie(bridge) ||
>   		    pci_pcie_type(bridge) == PCI_EXP_TYPE_PCI_BRIDGE)
> -			return 0;
> +			return false;
>   		/* If we found the root port, look it up in the ATSR */
>   		if (pci_pcie_type(bridge) == PCI_EXP_TYPE_ROOT_PORT)
>   			break;
> @@ -3085,18 +3085,21 @@ static int dmar_ats_supported(struct pci_dev *dev, struct intel_iommu *iommu)
>   		if (atsr->segment != pci_domain_nr(dev->bus))
>   			continue;
>   
> -		for_each_dev_scope(atsru->devices, atsru->devices_cnt, i, tmp)
> -			if (tmp == &bridge->dev)
> -				goto out;
> +		for_each_dev_scope(atsru->devices, atsru->devices_cnt, i, tmp) {
> +			if (tmp == &bridge->dev) {
> +				rcu_read_unlock();
> +				return true;
> +			}
> +		}
>   
> -		if (atsru->include_all)
> -			goto out;
> +		if (atsru->include_all) {
> +			rcu_read_unlock();
> +			return true;

It appears to me that two gotos is better than opening code. :) Anyhow.

Reviewed-by: Yi Liu <yi.l.liu@intel.com>


> +		}
>   	}
> -	ret = 0;
> -out:
>   	rcu_read_unlock();
>   
> -	return ret;
> +	return false;
>   }
>   
>   int dmar_iommu_notify_scope_dev(struct dmar_pci_notify_info *info)

-- 
Regards,
Yi Liu

  parent reply	other threads:[~2024-06-24  8:08 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-06-24  5:25 Lu Baolu
2024-06-24  5:25 ` [PATCH 2/2] iommu/vt-d: Remove hardware automatic ATS dependency Lu Baolu
2024-06-24  8:06   ` Yi Liu
2024-06-24  8:11     ` Baolu Lu
2024-06-25  2:32   ` Tian, Kevin
2024-06-25  8:40     ` Baolu Lu
2024-06-26  1:53       ` Tian, Kevin
2024-06-26  2:37         ` Baolu Lu
2024-06-24  8:12 ` Yi Liu [this message]
2024-06-25  2:28 ` [PATCH 1/2] iommu/vt-d: Convert dmar_ats_supported() to return bool Tian, Kevin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b5797453-3e19-469f-8a0b-71fe4c5add1a@intel.com \
    --to=yi.l.liu@intel.com \
    --cc=baolu.lu@linux.intel.com \
    --cc=iommu@lists.linux.dev \
    --cc=jacob.jun.pan@linux.intel.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®