From: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
To: xinlei.lee@mediatek.com, thierry.reding@gmail.com,
u.kleine-koenig@pengutronix.de, matthias.bgg@gmail.com
Cc: linux-pwm@vger.kernel.org, linux-mediatek@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org,
Project_Global_Chrome_Upstream_Group@mediatek.com,
jitao.shi@mediatek.com
Subject: Re: [PATCH,v2] pwm: mtk-disp: Fix the parameters calculated by the enabled flag of disp_pwm
Date: Mon, 26 Sep 2022 11:13:51 +0200 [thread overview]
Message-ID: <b594626f-5c73-2a4c-6286-81f9df26832e@collabora.com> (raw)
In-Reply-To: <1663934771-15152-1-git-send-email-xinlei.lee@mediatek.com>
Il 23/09/22 14:06, xinlei.lee@mediatek.com ha scritto:
> From: xinlei lee <xinlei.lee@mediatek.com>
>
> In the original mtk_disp_pwm_get_state() function, the result of reading
> con0 & BIT(0) is enabled as disp_pwm.
> In order to conform to the register table, we should use the disp_pwm
> base address as the enabled judgment.
>
> Fixes: 3f2b16734914 ("pwm: mtk-disp: Implement atomic API .get_state()")
>
> Signed-off-by: xinlei lee <xinlei.lee@mediatek.com>
> ---
> Base on the branch of Linux-next/master.
>
> change since v1:
> 1. Modify the way to set disp_pwm enbale.
> ---
> ---
> drivers/pwm/pwm-mtk-disp.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/pwm/pwm-mtk-disp.c b/drivers/pwm/pwm-mtk-disp.c
> index c605013..1a9880d 100644
> --- a/drivers/pwm/pwm-mtk-disp.c
> +++ b/drivers/pwm/pwm-mtk-disp.c
> @@ -197,7 +197,7 @@ static void mtk_disp_pwm_get_state(struct pwm_chip *chip,
> rate = clk_get_rate(mdp->clk_main);
> con0 = readl(mdp->base + mdp->data->con0);
> con1 = readl(mdp->base + mdp->data->con1);
> - state->enabled = !!(con0 & BIT(0));
> + state->enabled = !!(readl(mdp->base + DISP_PWM_EN) & BIT(0));
I think you mean mdp->data->enable_mask here.
Anyway, for the sake of human readability....
u32 clk_div, pwm_en, con0, con1;
pwm_en = readl(mdp->base + DISP_PWM_EN);
state->enabled = !!(pwm_en & mdp->data->enable_mask);
Regards,
Angelo
> clk_div = FIELD_GET(PWM_CLKDIV_MASK, con0);
> period = FIELD_GET(PWM_PERIOD_MASK, con1);
> /*
>
prev parent reply other threads:[~2022-09-26 9:14 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-09-23 12:06 xinlei.lee
2022-09-26 9:13 ` AngeloGioacchino Del Regno [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b594626f-5c73-2a4c-6286-81f9df26832e@collabora.com \
--to=angelogioacchino.delregno@collabora.com \
--cc=Project_Global_Chrome_Upstream_Group@mediatek.com \
--cc=jitao.shi@mediatek.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux-pwm@vger.kernel.org \
--cc=matthias.bgg@gmail.com \
--cc=thierry.reding@gmail.com \
--cc=u.kleine-koenig@pengutronix.de \
--cc=xinlei.lee@mediatek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®