From: Thomas Zimmermann <tzimmermann@suse.de>
To: Wu Hoi Pok <wuhoipok@gmail.com>
Cc: "Alex Deucher" <alexander.deucher@amd.com>,
"Christian König" <christian.koenig@amd.com>,
"Pan, Xinhui" <Xinhui.Pan@amd.com>,
"David Airlie" <airlied@gmail.com>,
"Daniel Vetter" <daniel@ffwll.ch>,
amd-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 1/6] drm/radeon: change variable name "dev" to "ddev" for consistency
Date: Wed, 3 Jul 2024 10:42:12 +0200 [thread overview]
Message-ID: <b5a86d3b-2824-4709-8afd-cc93addc0989@suse.de> (raw)
In-Reply-To: <20240630165949.117634-2-wuhoipok@gmail.com>
Am 30.06.24 um 18:59 schrieb Wu Hoi Pok:
> In the probe function of amdgpu, it uses "ddev" as the name of "struct drm_device *",
> so I suggest renaming it to be consistent.
>
> Signed-off-by: Wu Hoi Pok <wuhoipok@gmail.com>
Reviewed-by: Thomas Zimmermann <tzimmermann@suse.de>
Tested-by: Thomas Zimmermann <tzimmermann@suse.de>
> ---
> drivers/gpu/drm/radeon/radeon_drv.c | 16 ++++++++--------
> 1 file changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/gpu/drm/radeon/radeon_drv.c b/drivers/gpu/drm/radeon/radeon_drv.c
> index 7bf08164140e..739bb1da9dcc 100644
> --- a/drivers/gpu/drm/radeon/radeon_drv.c
> +++ b/drivers/gpu/drm/radeon/radeon_drv.c
> @@ -259,7 +259,7 @@ static int radeon_pci_probe(struct pci_dev *pdev,
> const struct pci_device_id *ent)
> {
> unsigned long flags = 0;
> - struct drm_device *dev;
> + struct drm_device *ddev;
> int ret;
>
> if (!ent)
> @@ -300,28 +300,28 @@ static int radeon_pci_probe(struct pci_dev *pdev,
> if (ret)
> return ret;
>
> - dev = drm_dev_alloc(&kms_driver, &pdev->dev);
> - if (IS_ERR(dev))
> - return PTR_ERR(dev);
> + ddev = drm_dev_alloc(&kms_driver, &pdev->dev);
> + if (IS_ERR(ddev))
> + return PTR_ERR(ddev);
>
> ret = pci_enable_device(pdev);
> if (ret)
> goto err_free;
>
> - pci_set_drvdata(pdev, dev);
> + pci_set_drvdata(pdev, ddev);
>
> - ret = drm_dev_register(dev, ent->driver_data);
> + ret = drm_dev_register(ddev, ent->driver_data);
> if (ret)
> goto err_agp;
>
> - radeon_fbdev_setup(dev->dev_private);
> + radeon_fbdev_setup(ddev->dev_private);
>
> return 0;
>
> err_agp:
> pci_disable_device(pdev);
> err_free:
> - drm_dev_put(dev);
> + drm_dev_put(ddev);
> return ret;
> }
>
--
--
Thomas Zimmermann
Graphics Driver Developer
SUSE Software Solutions Germany GmbH
Frankenstrasse 146, 90461 Nuernberg, Germany
GF: Ivo Totev, Andrew Myers, Andrew McDonald, Boudien Moerman
HRB 36809 (AG Nuernberg)
next prev parent reply other threads:[~2024-07-03 8:42 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-06-30 16:59 [PATCH v3 0/6] drm/radeon: remove load callback & drm_dev_alloc Wu Hoi Pok
2024-06-30 16:59 ` [PATCH v3 1/6] drm/radeon: change variable name "dev" to "ddev" for consistency Wu Hoi Pok
2024-07-03 8:42 ` Thomas Zimmermann [this message]
2024-06-30 16:59 ` [PATCH v3 2/6] drm/radeon: remove load callback from kms_driver Wu Hoi Pok
2024-07-03 8:43 ` Thomas Zimmermann
2024-09-19 16:56 ` Arthur Marsh
2024-09-24 2:08 ` radeon ARUBA NULL pointer dereference Arthur Marsh
2024-09-24 12:20 ` Thomas Zimmermann
2024-09-24 12:42 ` Thomas Zimmermann
2024-09-24 14:22 ` Alex Deucher
2024-09-24 19:30 ` Ewan Milne
2024-09-25 18:13 ` Ewan Milne
2024-09-25 0:22 ` NULL pointer dereference after ib test on ring 7 succeeded Arthur Marsh
2024-09-25 8:02 ` Thomas Zimmermann
2024-09-30 15:25 ` NULL pointer dereference with kernel 6.12.0-rc1 and ARUBA GPU Arthur Marsh
2024-09-30 17:54 ` Christian König
2024-10-07 12:44 ` Thomas Zimmermann
2024-06-30 16:59 ` [PATCH v3 3/6] drm/radeon: use variable flags as parameter Wu Hoi Pok
2024-07-03 8:44 ` Thomas Zimmermann
2024-06-30 16:59 ` [PATCH v3 4/6] drm/radeon: add helper rdev_to_drm(rdev) Wu Hoi Pok
2024-07-03 8:44 ` Thomas Zimmermann
2024-06-30 16:59 ` [PATCH v3 5/6] drm/radeon: change rdev->ddev to rdev_to_drm(rdev) Wu Hoi Pok
2024-07-03 8:46 ` Thomas Zimmermann
2024-06-30 16:59 ` [PATCH v3 6/6] drm/radeon: change drm_dev_alloc to devm_drm_dev_alloc Wu Hoi Pok
2024-07-03 8:47 ` Thomas Zimmermann
2024-07-08 20:04 ` Alex Deucher
2024-07-03 8:52 ` [PATCH v3 0/6] drm/radeon: remove load callback & drm_dev_alloc Thomas Zimmermann
2024-07-04 4:58 ` Hoi Pok Wu
2024-07-04 13:02 ` Christian König
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b5a86d3b-2824-4709-8afd-cc93addc0989@suse.de \
--to=tzimmermann@suse.de \
--cc=Xinhui.Pan@amd.com \
--cc=airlied@gmail.com \
--cc=alexander.deucher@amd.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=christian.koenig@amd.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=wuhoipok@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®