From: claudiu beznea <claudiu.beznea@tuxon.dev>
To: Manikandan Muralidharan <manikandan.m@microchip.com>,
sam@ravnborg.org, bbrezillon@kernel.org,
maarten.lankhorst@linux.intel.com, mripard@kernel.org,
tzimmermann@suse.de, airlied@gmail.com, daniel@ffwll.ch,
nicolas.ferre@microchip.com, alexandre.belloni@bootlin.com,
lee@kernel.org, dri-devel@lists.freedesktop.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org
Cc: Hari.PrasathGE@microchip.com,
Balamanikandan.Gunasundar@microchip.com,
Durai.ManickamKR@microchip.com, Nayabbasha.Sayed@microchip.com,
Dharma.B@microchip.com, Varshini.Rajendran@microchip.com,
Balakrishnan.S@microchip.com, Charan.Pedumuru@microchip.com
Subject: Re: [PATCH v8 0/7] Add support for XLCDC to sam9x7 SoC family.
Date: Sat, 24 Feb 2024 14:52:09 +0200 [thread overview]
Message-ID: <b5d9b028-4a1e-4bbd-9572-290b0042afdc@tuxon.dev> (raw)
In-Reply-To: <20240221053531.12701-1-manikandan.m@microchip.com>
Hi, Manikandan,
On 21.02.2024 07:35, Manikandan Muralidharan wrote:
> This patch series aims to add support for XLCDC IP of sam9x7 SoC family
> to the DRM subsystem.XLCDC IP has additional registers and new
> configuration bits compared to the existing register set of HLCDC IP.
> The new compatible string "microchip,sam9x75-xlcdc" is defined for sam9x75
> variant of the sam9x7 SoC family.The is_xlcdc flag under driver data and
> IP specific driver ops helps to differentiate the XLCDC and existing HLCDC
> code within the same driver.
>
> changes in v8:
> * Re-arrange the patch set to prepare and update the current HLCDC
> code base with the new LCDC IP based driver ops and then add support
> for XLCDC code changes.
> * Fix Cosmetic issues.
>
> changes in v7:
> * LCDC IP driver ops functions are declared static and its
> declaration are removed.
>
> changes in v6:
> * Fixed Cosmetic defects.
> * Added comments for readability.
>
> changes in v5:
> * return value of regmap_read_poll_timeout is checked in failure
> case.
> * HLCDC and XLCDC specific driver functions are now invoked
> using its IP specific driver ops w/o the need of checking is_xlcdc flag.
> * Removed empty spaces and blank lines.
>
> changes in v4:
> * fixed kernel warnings reported by kernel test robot.
>
> changes in v3:
> * Removed de-referencing the value of is_xlcdc flag multiple times in
> a single function.
> * Removed cpu_relax() call when using regmap_read_poll_timeout.
> * Updated xfactor and yfactor equations using shift operators
> * Defined CSC co-efficients in an array for code readability.
>
> changes in v2:
> * Change the driver compatible name from "microchip,sam9x7-xlcdc" to
> "microchip,sam9x75-xlcdc".
> * Move is_xlcdc flag to driver data.
> * Remove unsed Macro definitions.
> * Add co-developed-bys tags
> * Replace regmap_read() with regmap_read_poll_timeout() call
> * Split code into two helpers for code readablitity.
> ---
>
> Durai Manickam KR (1):
> drm: atmel-hlcdc: Define XLCDC specific registers
>
> Manikandan Muralidharan (6):
> drm: atmel-hlcdc: add driver ops to differentiate HLCDC and XLCDC IP
> drm: atmel_hlcdc: Add support for XLCDC using IP specific driver ops
> drm: atmel-hlcdc: add DPI mode support for XLCDC
> drm: atmel-hlcdc: add vertical and horizontal scaling support for
> XLCDC
> drm: atmel-hlcdc: add support for DSI output formats
> drm: atmel-hlcdc: add LCD controller layer definition for sam9x75
>
Only minor comments from me (check individual patches). W/ or w/o those
addressed you can add:
Reviewed-by: Claudiu Beznea <claudiu.beznea@tuxon.dev>
prev parent reply other threads:[~2024-02-24 12:52 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-02-21 5:35 Manikandan Muralidharan
2024-02-21 5:35 ` [PATCH v8 1/7] drm: atmel-hlcdc: add driver ops to differentiate HLCDC and XLCDC IP Manikandan Muralidharan
2024-02-24 12:50 ` claudiu beznea
2024-02-21 5:35 ` [PATCH v8 2/7] drm: atmel-hlcdc: Define XLCDC specific registers Manikandan Muralidharan
2024-02-23 17:04 ` Lee Jones
2024-02-21 5:35 ` [PATCH v8 3/7] drm: atmel_hlcdc: Add support for XLCDC using IP specific driver ops Manikandan Muralidharan
2024-02-24 12:50 ` claudiu beznea
2024-02-21 5:35 ` [PATCH v8 4/7] drm: atmel-hlcdc: add DPI mode support for XLCDC Manikandan Muralidharan
2024-02-21 5:35 ` [PATCH v8 5/7] drm: atmel-hlcdc: add vertical and horizontal scaling " Manikandan Muralidharan
2024-02-21 5:35 ` [PATCH v8 6/7] drm: atmel-hlcdc: add support for DSI output formats Manikandan Muralidharan
2024-02-24 12:50 ` claudiu beznea
2024-02-21 5:35 ` [PATCH v8 7/7] drm: atmel-hlcdc: add LCD controller layer definition for sam9x75 Manikandan Muralidharan
2024-02-22 16:35 ` [PATCH v8 0/7] Add support for XLCDC to sam9x7 SoC family Sam Ravnborg
2024-02-24 12:52 ` claudiu beznea [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b5d9b028-4a1e-4bbd-9572-290b0042afdc@tuxon.dev \
--to=claudiu.beznea@tuxon.dev \
--cc=Balakrishnan.S@microchip.com \
--cc=Balamanikandan.Gunasundar@microchip.com \
--cc=Charan.Pedumuru@microchip.com \
--cc=Dharma.B@microchip.com \
--cc=Durai.ManickamKR@microchip.com \
--cc=Hari.PrasathGE@microchip.com \
--cc=Nayabbasha.Sayed@microchip.com \
--cc=Varshini.Rajendran@microchip.com \
--cc=airlied@gmail.com \
--cc=alexandre.belloni@bootlin.com \
--cc=bbrezillon@kernel.org \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=lee@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=manikandan.m@microchip.com \
--cc=mripard@kernel.org \
--cc=nicolas.ferre@microchip.com \
--cc=sam@ravnborg.org \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®